aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-HTML-Tidy/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-06-09 12:15:32 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-06-09 12:15:32 +0000
commit97033c4d6d0d9833f7312d1ff3ab416b67f99432 (patch)
tree636db9052d78153cb3cf35b1886e126c863c6195 /textproc/p5-HTML-Tidy/Makefile
parentf90b3577ae61be7ca2e9f8cf78e51f06e1401181 (diff)
downloadports-97033c4d6d0d9833f7312d1ff3ab416b67f99432.tar.gz
ports-97033c4d6d0d9833f7312d1ff3ab416b67f99432.zip
Notes
Diffstat (limited to 'textproc/p5-HTML-Tidy/Makefile')
-rw-r--r--textproc/p5-HTML-Tidy/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/textproc/p5-HTML-Tidy/Makefile b/textproc/p5-HTML-Tidy/Makefile
new file mode 100644
index 000000000000..8a72bcc9b761
--- /dev/null
+++ b/textproc/p5-HTML-Tidy/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-HTML-Tidy
+# Date Created: 8 june 2004
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Tidy
+PORTVERSION= 1.04
+CATEGORIES= textproc www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Web validation in a Perl object using tidy
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+LIB_DEPENDS= tidy:${PORTSDIR}/www/tidy-lib
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Tidy.3 HTML::Tidy::Message.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Needs perl 5.6 or higher, install lang/perl5 or lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>