aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-MARC-XML/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2009-08-06 11:11:09 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2009-08-06 11:11:09 +0000
commit732e202086524ba61e85d3f381ab049de3112fee (patch)
tree2c52ef9827a8064d8542ad90b595ae59711fd941 /textproc/p5-MARC-XML/Makefile
parent3ec8220c31c2d33466d28ad1655c294ec92afb57 (diff)
downloadports-732e202086524ba61e85d3f381ab049de3112fee.tar.gz
ports-732e202086524ba61e85d3f381ab049de3112fee.zip
Notes
Diffstat (limited to 'textproc/p5-MARC-XML/Makefile')
-rw-r--r--textproc/p5-MARC-XML/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/p5-MARC-XML/Makefile b/textproc/p5-MARC-XML/Makefile
new file mode 100644
index 000000000000..792ceecc36e7
--- /dev/null
+++ b/textproc/p5-MARC-XML/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-MARC-XML
+# Date created: 6 August 2009
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MARC-XML
+PORTVERSION= 0.92
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= An extension to the MARC-Record distribution for working with XML data
+
+BUILD_DEPENDS= ${SITE_PERL}/MARC/Record.pm:${PORTSDIR}/textproc/p5-MARC-Record \
+ ${SITE_PERL}/MARC/Charset.pm:${PORTSDIR}/textproc/p5-MARC-Charset \
+ ${SITE_PERL}/XML/SAX.pm:${PORTSDIR}/textproc/p5-XML-SAX
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN1= marc2xml.1 xml2marc.1
+MAN3= MARC::File::SAX.3 MARC::File::XML.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>