aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Makefile-Parser
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-04-11 13:30:05 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-04-11 13:30:05 +0000
commit0c3674981cad76fa67016cd11d55c7d0aa4337fc (patch)
tree8b3baf470657b1430d01826b64a98b78c7523f5b /textproc/p5-Makefile-Parser
parenta031a0d8b96523832995fccded353c0b6ecd2b08 (diff)
Notes
Diffstat (limited to 'textproc/p5-Makefile-Parser')
-rw-r--r--textproc/p5-Makefile-Parser/Makefile28
-rw-r--r--textproc/p5-Makefile-Parser/distinfo3
-rw-r--r--textproc/p5-Makefile-Parser/pkg-descr5
-rw-r--r--textproc/p5-Makefile-Parser/pkg-plist5
4 files changed, 41 insertions, 0 deletions
diff --git a/textproc/p5-Makefile-Parser/Makefile b/textproc/p5-Makefile-Parser/Makefile
new file mode 100644
index 000000000000..2fed1426340a
--- /dev/null
+++ b/textproc/p5-Makefile-Parser/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: textproc/p5-Makefile-Parser
+# Date created: 11 April 2006
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Makefile-Parser
+PORTVERSION= 0.11
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/A/AG/AGENT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Makefile::Parser - A Simple Parser for Makefiles
+
+PERL_CONFIGURE= yes
+
+MAN3= Makefile::Parser.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Makefile-Parser/distinfo b/textproc/p5-Makefile-Parser/distinfo
new file mode 100644
index 000000000000..d66e41591d51
--- /dev/null
+++ b/textproc/p5-Makefile-Parser/distinfo
@@ -0,0 +1,3 @@
+MD5 (Makefile-Parser-0.11.tar.gz) = 39730533c31b1785a3a2cad1f9348f8f
+SHA256 (Makefile-Parser-0.11.tar.gz) = 438487f2e3ea8801e9ab66e8e84061c487fd5e7012f2bebfbee91684a989ca51
+SIZE (Makefile-Parser-0.11.tar.gz) = 19083
diff --git a/textproc/p5-Makefile-Parser/pkg-descr b/textproc/p5-Makefile-Parser/pkg-descr
new file mode 100644
index 000000000000..412f78ca9234
--- /dev/null
+++ b/textproc/p5-Makefile-Parser/pkg-descr
@@ -0,0 +1,5 @@
+This is a parser for Makefiles. At this very early stage, the parser
+only supports a limited set of features, so it may not recognize some
+advanced features provided by certain make tools like GNU make.
+
+WWW: http://search.cpan.org/dist/Makefile-Parser/
diff --git a/textproc/p5-Makefile-Parser/pkg-plist b/textproc/p5-Makefile-Parser/pkg-plist
new file mode 100644
index 000000000000..2a0ee9c94cee
--- /dev/null
+++ b/textproc/p5-Makefile-Parser/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Makefile/Parser.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Makefile/Parser/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Makefile/Parser
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Makefile
+@dirrmtry %%SITE_PERL%%/Makefile