aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-PDF-Create
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2009-03-27 09:27:31 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2009-03-27 09:27:31 +0000
commite2b0522ca7da111da1c4ef16706760ca5b13a2c1 (patch)
treeb4b6e0e1252c5dcb4b658b499c5c7e4580987837 /textproc/p5-PDF-Create
parent58247e09a550a888b98b7aa36a7f1472704b2620 (diff)
downloadports-e2b0522ca7da111da1c4ef16706760ca5b13a2c1.tar.gz
ports-e2b0522ca7da111da1c4ef16706760ca5b13a2c1.zip
Notes
Diffstat (limited to 'textproc/p5-PDF-Create')
-rw-r--r--textproc/p5-PDF-Create/Makefile2
-rw-r--r--textproc/p5-PDF-Create/distinfo6
-rw-r--r--textproc/p5-PDF-Create/files/patch-Changes.PL48
3 files changed, 46 insertions, 10 deletions
diff --git a/textproc/p5-PDF-Create/Makefile b/textproc/p5-PDF-Create/Makefile
index 3dce1dddf855..f969ffdd2560 100644
--- a/textproc/p5-PDF-Create/Makefile
+++ b/textproc/p5-PDF-Create/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= PDF-Create
-PORTVERSION= 1.02
+PORTVERSION= 1.03
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/textproc/p5-PDF-Create/distinfo b/textproc/p5-PDF-Create/distinfo
index 3b57d1b4fbc1..62bdaac30131 100644
--- a/textproc/p5-PDF-Create/distinfo
+++ b/textproc/p5-PDF-Create/distinfo
@@ -1,3 +1,3 @@
-MD5 (PDF-Create-1.02.tar.gz) = b63aac40dad00c69edd8144a7c59f716
-SHA256 (PDF-Create-1.02.tar.gz) = 7c364bf27e77b7469076589d0c1cf94718dd6f8d9ef709a0a4fb7ceb325f25fc
-SIZE (PDF-Create-1.02.tar.gz) = 103401
+MD5 (PDF-Create-1.03.tar.gz) = 19f6c51d7c473c59909241269e048696
+SHA256 (PDF-Create-1.03.tar.gz) = 55274a5fda1a40b23efffad6e2bddf769a240c417a13f6f003a22debae147eeb
+SIZE (PDF-Create-1.03.tar.gz) = 103334
diff --git a/textproc/p5-PDF-Create/files/patch-Changes.PL b/textproc/p5-PDF-Create/files/patch-Changes.PL
index d9063414af9c..f94222d63f51 100644
--- a/textproc/p5-PDF-Create/files/patch-Changes.PL
+++ b/textproc/p5-PDF-Create/files/patch-Changes.PL
@@ -1,9 +1,45 @@
---- Changes.PL.orig 2008-06-04 14:09:50.000000000 +0200
-+++ Changes.PL 2008-06-04 14:08:31.000000000 +0200
-@@ -7,5 +7,5 @@
+--- Changes.PL.orig 2009-03-23 23:50:18.000000000 +0000
++++ Changes.PL 2009-03-27 09:12:48.000000000 +0000
+@@ -3,12 +3,39 @@
+ # Changes.PL
+ #
+ # Create the 'Changes' file automatically from git commit messages
+-# and versioning tags in the repository
++# and versioning tags in the repository.
++#
++# This script is designed to be run only on the PDF::Create maintainers
++# workstation and is not needed to install PDF::Create.
++#
use strict;
--`git log --abbrev-commit --pretty > Changes`;
-+#`git log --abbrev-commit --pretty > Changes`;
-
+-open(OUT, ">Changes") or die "Can not open 'Changes' for writing\n";
+-open(IN,"git log --abbrev-commit --pretty |") or die "Can not run git\n";
++#
++# Bail out with non-alarming error message if git ot the correct repository
++# is missing.
++#
++
++my $user;
++my $git=`which git`;
++chomp $git;
++if (! (-f $git)) {
++ printf "Skipping... (git not found/installed)\n";
++ exit (0);
++}
++
++if (! ($user=`git config --get user.name 2>/dev/null`)) {
++ printf "Skipping... (git not found/installed)\n";
++ exit (0);
++}
++chop $user;
++if ("$user" ne "Markus Baertschi") {
++ printf "Skipping... (not on maintainers workstation)\n";
++ exit (0);
++}
++
++open(OUT,">Changes") or die "Can not open 'Changes' for writing\n";
++open(IN,"git log --abbrev-commit --pretty |") or die "Problem running git log\n";
+ while(<IN>){
+ # read the change log
+ if (/^commit /) {