aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-PPI-XS/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2007-05-26 16:12:05 +0000
committerLars Thegler <lth@FreeBSD.org>2007-05-26 16:12:05 +0000
commit08803e2f4621e1df123fa2abb9cce833739ad574 (patch)
treef12293d5764a3a03a371c21a613fa3a9e9658622 /textproc/p5-PPI-XS/Makefile
parent7cd4402a2b0f5cf27aa2e6fb23718ac59ea2031c (diff)
Notes
Diffstat (limited to 'textproc/p5-PPI-XS/Makefile')
-rw-r--r--textproc/p5-PPI-XS/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/p5-PPI-XS/Makefile b/textproc/p5-PPI-XS/Makefile
new file mode 100644
index 000000000000..8a0e69037038
--- /dev/null
+++ b/textproc/p5-PPI-XS/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: textproc/p5-PPI-XS
+# Date created: 09 May 2007
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PPI-XS
+PORTVERSION= 0.900
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= PPI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= XS acceleration for the PPI perl parser
+
+RUN_DEPENDS= p5-PPI>=0.845:${PORTSDIR}/textproc/p5-PPI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= PPI::XS.3
+
+post-patch:
+ ${PERL} -pi -e '$$_="" if /auto_install/' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>