aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Perl-MinimumVersion/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-10-26 08:17:46 +0000
committerLars Thegler <lth@FreeBSD.org>2005-10-26 08:17:46 +0000
commitc25ca102c507c8226e77ebacd21cbc769647f976 (patch)
tree866f509872b31c51481ed7c35a3aa927d5ccdfcf /textproc/p5-Perl-MinimumVersion/Makefile
parentf24eab01de7dd70b5d5d357b65e47e60609d7428 (diff)
downloadports-c25ca102c507c8226e77ebacd21cbc769647f976.tar.gz
ports-c25ca102c507c8226e77ebacd21cbc769647f976.zip
Notes
Diffstat (limited to 'textproc/p5-Perl-MinimumVersion/Makefile')
-rw-r--r--textproc/p5-Perl-MinimumVersion/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/textproc/p5-Perl-MinimumVersion/Makefile b/textproc/p5-Perl-MinimumVersion/Makefile
new file mode 100644
index 000000000000..3c1ae5d80487
--- /dev/null
+++ b/textproc/p5-Perl-MinimumVersion/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: textproc/p5-Perl-MinimumVersion
+# Date created: 25 October 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Perl-MinimumVersion
+PORTVERSION= 0.10
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Perl
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Find a minimum required version of perl for Perl code
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
+ ${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/PPI.pm:${PORTSDIR}/textproc/p5-PPI \
+ ${SITE_PERL}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= perlver.1
+MAN3= Perl::MinimumVersion.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires Perl 5.8.1 or newer. Install lang/perl5.8 and try again.
+.endif
+
+post-patch:
+ @${RM} ${WRKSRC}/inc/Module/Install/AutoInstall.pm
+ @${PERL} -pi -e '$$_="" if m/AutoInstall/' ${WRKSRC}/MANIFEST
+ @${PERL} -pi -e '$$_="" if m/Test::More|auto_install/' ${WRKSRC}/Makefile.PL
+.include <bsd.port.post.mk>