aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Plucene-Simple/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-02 10:06:15 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-02 10:06:15 +0000
commit4e803096866cb72e99754042fd840f714893c081 (patch)
treef6af21525f1be393b2b13467a73abdbe2b51c3a2 /textproc/p5-Plucene-Simple/Makefile
parente4cb58ea1568edb74441f50528aa96fcbd807c1d (diff)
downloadports-4e803096866cb72e99754042fd840f714893c081.tar.gz
ports-4e803096866cb72e99754042fd840f714893c081.zip
Notes
Diffstat (limited to 'textproc/p5-Plucene-Simple/Makefile')
-rw-r--r--textproc/p5-Plucene-Simple/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/p5-Plucene-Simple/Makefile b/textproc/p5-Plucene-Simple/Makefile
new file mode 100644
index 000000000000..f96f38d1597f
--- /dev/null
+++ b/textproc/p5-Plucene-Simple/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Plucene-Simple
+# Date created: 2 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Plucene-Simple
+DISTVERSION= 1.04
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/S/ST/STRYTOAST
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME:S/-//}-${PORTVERSION}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= An interface to Plucene
+
+BUILD_DEPENDS= p5-Time-Piece>=1.08:${PORTSDIR}/devel/p5-Time-Piece \
+ p5-Time-Piece-Range>=1.0:${PORTSDIR}/devel/p5-Time-Piece-Range \
+ p5-Plucene>=1.09:${PORTSDIR}/textproc/p5-Plucene \
+ p5-File-Find-Rule>=0.10:${PORTSDIR}/devel/p5-File-Find-Rule \
+ p5-File-Slurp>=2002.1031:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-Test-Class>=0.03:${PORTSDIR}/devel/p5-Test-Class
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= YES
+
+MAN3= ${PORTNAME:S/-/::/g}.3
+
+.include <bsd.port.mk>