aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Pod-Parser/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2003-02-12 12:13:58 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2003-02-12 12:13:58 +0000
commit4c3ecaf6958c3e54ceb507bde9e94b989f1e5952 (patch)
tree0d6211b1c4bf47afd015f10446b366049c40df8e /textproc/p5-Pod-Parser/Makefile
parent440848820aff8c263c4865129aa9d16fa34f35db (diff)
Notes
Diffstat (limited to 'textproc/p5-Pod-Parser/Makefile')
-rw-r--r--textproc/p5-Pod-Parser/Makefile24
1 files changed, 4 insertions, 20 deletions
diff --git a/textproc/p5-Pod-Parser/Makefile b/textproc/p5-Pod-Parser/Makefile
index 57f5e2ccb18a..63cfbe83abda 100644
--- a/textproc/p5-Pod-Parser/Makefile
+++ b/textproc/p5-Pod-Parser/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= PodParser
-PORTVERSION= 1.18
+PORTVERSION= 1.21
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pod
@@ -14,8 +14,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MAN1= pod2usage.1 podchecker.1 podselect.1
@@ -30,23 +28,9 @@ post-patch:
.include <bsd.port.pre.mk>
-SITE_PERL?= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
-
-perl_major=${PERL_VERSION:C|^([1-9]+).*|\1|}
-_perl_minor=00${PERL_VERSION:C|^([1-9]+)\.([0-9]+).*|\2|}
-perl_minor=${_perl_minor:C|^.*(...)|\1|}
-.if ${perl_minor} >= 100
-perl_minor=${PERL_VERSION:C|^([1-9]+)\.([0-9][0-9][0-9]).*|\2|}
-perl_patch=${PERL_VERSION:C|^.*(..)|\1|}
-.else # ${perl_minor} < 100
-_perl_patch=0${PERL_VERSION:C|^([1-9]+)\.([0-9]+)\.*|0|}
-perl_patch=${_perl_patch:C|^.*(..)|\1|}
-.endif # ${perl_minor} < 100
-PERL_LEVEL=${perl_major}${perl_minor}${perl_patch}
-
-BUILD_DEPENDS=
.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif # ${PERL_LEVEL} < 500601
+BUILD_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
.include <bsd.port.post.mk>