aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Pod-Parser
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2005-03-16 19:05:38 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2005-03-16 19:05:38 +0000
commit00987de3264dc3f011b1120067176254391272b0 (patch)
treedce901d935970564e3cc0ebacafed349b8cd7c05 /textproc/p5-Pod-Parser
parentbe6115ff906e8ee2c92d422131a76f7f37ff2cbb (diff)
downloadports-00987de3264dc3f011b1120067176254391272b0.tar.gz
ports-00987de3264dc3f011b1120067176254391272b0.zip
Notes
Diffstat (limited to 'textproc/p5-Pod-Parser')
-rw-r--r--textproc/p5-Pod-Parser/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/textproc/p5-Pod-Parser/Makefile b/textproc/p5-Pod-Parser/Makefile
index 17e68b754b8d..f1d062ba1825 100644
--- a/textproc/p5-Pod-Parser/Makefile
+++ b/textproc/p5-Pod-Parser/Makefile
@@ -7,7 +7,7 @@
PORTNAME= PodParser
PORTVERSION= 1.28
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pod
@@ -16,6 +16,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Modules to work with POD (Plain Old Documentation)
+BUILD_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
CONFIGURE_ARGS= INSTALLDIRS="site"
@@ -26,19 +29,16 @@ MAN3= Pod::Checker.3 Pod::Find.3 Pod::InputObjects.3 \
.include <bsd.port.pre.mk>
-PLIST_SUB= PL_FILES=""
-
.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-RUN_DEPENDS= ${BUILD_DEPENDS}
-.elif ${PERL_LEVEL} < 500802
+PLIST_SUB+= PL_FILES=""
+.else
.undef MAN1
-PLIST_SUB= PL_FILES="@comment "
+PLIST_SUB+= PL_FILES="@comment "
.endif
post-patch:
-.if ${PERL_LEVEL} >= 500600 && ${PERL_LEVEL} < 500802
- @${PERL} -pi -e 'm,_FILES, && s,.,,sg' ${WRKSRC}/Makefile.PL
+.if ${PERL_LEVEL} >= 500600
+ @${REINPLACE_CMD} -e '/EXE_FILES/d' ${WRKSRC}/Makefile.PL
.endif
@${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;