aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Pod-Parser
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-08-10 19:01:26 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-08-10 19:01:26 +0000
commit4f7fcd1bccb37848f412426a0b168f0845ac7d68 (patch)
treecba6a402318fe1d42315e86ca1845fef651cb9b0 /textproc/p5-Pod-Parser
parent1d76dde1a4d7ce082e2d8bd8d2f6e2f5f7615b7d (diff)
downloadports-4f7fcd1bccb37848f412426a0b168f0845ac7d68.tar.gz
ports-4f7fcd1bccb37848f412426a0b168f0845ac7d68.zip
Notes
Diffstat (limited to 'textproc/p5-Pod-Parser')
-rw-r--r--textproc/p5-Pod-Parser/Makefile21
-rw-r--r--textproc/p5-Pod-Parser/pkg-descr3
-rw-r--r--textproc/p5-Pod-Parser/pkg-plist6
3 files changed, 17 insertions, 13 deletions
diff --git a/textproc/p5-Pod-Parser/Makefile b/textproc/p5-Pod-Parser/Makefile
index e4fc220ae6be..17e68b754b8d 100644
--- a/textproc/p5-Pod-Parser/Makefile
+++ b/textproc/p5-Pod-Parser/Makefile
@@ -7,6 +7,7 @@
PORTNAME= PodParser
PORTVERSION= 1.28
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pod
@@ -23,16 +24,22 @@ MAN3= Pod::Checker.3 Pod::Find.3 Pod::InputObjects.3 \
Pod::ParseUtils.3 Pod::Parser.3 Pod::PlainText.3 Pod::Select.3 \
Pod::Usage.3
-CONFLICTS= perl-5.6.* perl-5.8.*
+.include <bsd.port.pre.mk>
-post-patch:
- @${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
+PLIST_SUB= PL_FILES=""
-.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.elif ${PERL_LEVEL} < 500802
+.undef MAN1
+PLIST_SUB= PL_FILES="@comment "
+.endif
-.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-RUN_DEPENDS+= ${BUILD_DEPENDS}
+post-patch:
+.if ${PERL_LEVEL} >= 500600 && ${PERL_LEVEL} < 500802
+ @${PERL} -pi -e 'm,_FILES, && s,.,,sg' ${WRKSRC}/Makefile.PL
.endif
+ @${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
.include <bsd.port.post.mk>
diff --git a/textproc/p5-Pod-Parser/pkg-descr b/textproc/p5-Pod-Parser/pkg-descr
index dbfd043fc772..52476fcb8f2b 100644
--- a/textproc/p5-Pod-Parser/pkg-descr
+++ b/textproc/p5-Pod-Parser/pkg-descr
@@ -10,6 +10,3 @@ Set of modules:
* Pod::Find - find POD documents in directory trees
WWW: http://search.cpan.org/dist/PodParser/
-
--- Sergey Skvortsov
-skv@FreeBSD.org
diff --git a/textproc/p5-Pod-Parser/pkg-plist b/textproc/p5-Pod-Parser/pkg-plist
index 1fce1057e5e8..767ad94ec02d 100644
--- a/textproc/p5-Pod-Parser/pkg-plist
+++ b/textproc/p5-Pod-Parser/pkg-plist
@@ -1,6 +1,6 @@
-bin/pod2usage
-bin/podchecker
-bin/podselect
+%%PL_FILES%%bin/pod2usage
+%%PL_FILES%%bin/podchecker
+%%PL_FILES%%bin/podselect
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Parser/.packlist
%%SITE_PERL%%/Pod/Checker.pm
%%SITE_PERL%%/Pod/Find.pm