aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Pod-Stripper
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2003-11-18 16:00:54 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2003-11-18 16:00:54 +0000
commitc66670b5ae997c6e33f034d58f8ad72c50afd2cb (patch)
treed415c40988ff6e61b8395c33d533d1780511af17 /textproc/p5-Pod-Stripper
parent02820467410cc0d14ca70b897ce729130af044b9 (diff)
Add p5-Pod-Stripper 0.22, strip all pod, and output what's left.
Notes
Notes: svn path=/head/; revision=94275
Diffstat (limited to 'textproc/p5-Pod-Stripper')
-rw-r--r--textproc/p5-Pod-Stripper/Makefile31
-rw-r--r--textproc/p5-Pod-Stripper/distinfo1
-rw-r--r--textproc/p5-Pod-Stripper/pkg-descr8
-rw-r--r--textproc/p5-Pod-Stripper/pkg-plist6
4 files changed, 46 insertions, 0 deletions
diff --git a/textproc/p5-Pod-Stripper/Makefile b/textproc/p5-Pod-Stripper/Makefile
new file mode 100644
index 000000000000..39e2e9844094
--- /dev/null
+++ b/textproc/p5-Pod-Stripper/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Pod-Stripper
+# Date created: 18 November 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Pod-Stripper
+PORTVERSION= 0.22
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Pod
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Strip all pod, and output what's left
+
+BUILD_DEPENDS= ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS+= INSTALLDIRS="site"
+
+MAN1= podstrip.1
+MAN3= Pod::Stripper.3
+MAN1PREFIX= ${PREFIX}
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f|${XARGS} ${PERL} -pi -e 's/\x0d(?=\x0a)//;'
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Pod-Stripper/distinfo b/textproc/p5-Pod-Stripper/distinfo
new file mode 100644
index 000000000000..36ca5a9088a9
--- /dev/null
+++ b/textproc/p5-Pod-Stripper/distinfo
@@ -0,0 +1 @@
+MD5 (Pod-Stripper-0.22.tar.gz) = 33095c075bcb8f366a3fb3bf2c1d3fc8
diff --git a/textproc/p5-Pod-Stripper/pkg-descr b/textproc/p5-Pod-Stripper/pkg-descr
new file mode 100644
index 000000000000..92c4465e3b8a
--- /dev/null
+++ b/textproc/p5-Pod-Stripper/pkg-descr
@@ -0,0 +1,8 @@
+This be Pod::Stripper, a subclass of Pod::Parser. It parses perl files,
+stripping out the pod, and dumping the rest (presumably code) to
+wherever you point it to (like you do with Pod::Parser).
+
+WWW: http://search.cpan.org/dist/Pod-Stripper/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/textproc/p5-Pod-Stripper/pkg-plist b/textproc/p5-Pod-Stripper/pkg-plist
new file mode 100644
index 000000000000..cfe1a215dd09
--- /dev/null
+++ b/textproc/p5-Pod-Stripper/pkg-plist
@@ -0,0 +1,6 @@
+bin/podstrip
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Stripper/.packlist
+%%SITE_PERL%%/Pod/Stripper.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Stripper
+@unexec rmdir %D/%%SITE_PERL%%/Pod 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod 2>/dev/null || true