aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Pod-Tree/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2009-04-23 23:28:33 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2009-04-23 23:28:33 +0000
commitef8da359d0cf185474ef904640a560e2a75917f0 (patch)
tree6fbe117a8ee249fc87d217d7a2bbaf802328ce95 /textproc/p5-Pod-Tree/Makefile
parentcaf42bbc1f8720872b00f73055a14eea16a60aba (diff)
Notes
Diffstat (limited to 'textproc/p5-Pod-Tree/Makefile')
-rw-r--r--textproc/p5-Pod-Tree/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/textproc/p5-Pod-Tree/Makefile b/textproc/p5-Pod-Tree/Makefile
index 637d214508d0..2391c00f2303 100644
--- a/textproc/p5-Pod-Tree/Makefile
+++ b/textproc/p5-Pod-Tree/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= Pod-Tree
-PORTVERSION= 1.15
+PORTVERSION= 1.16
CATEGORIES= textproc devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,15 +15,14 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Create a static syntax tree for a POD
-RUN_DEPENDS= ${SITE_PERL}/HTML/Stream.pm:${PORTSDIR}/www/p5-HTML-Stream \
- ${SITE_PERL}/Text/Template.pm:${PORTSDIR}/textproc/p5-Text-Template \
- ${SITE_PERL}/Pod/Escapes.pm:${PORTSDIR}/textproc/p5-Pod-Escapes
+RUN_DEPENDS= p5-HTML-Stream>=1.49:${PORTSDIR}/www/p5-HTML-Stream \
+ p5-IO-String>=1:${PORTSDIR}/devel/p5-IO-String \
+ p5-Text-Template>=1:${PORTSDIR}/textproc/p5-Text-Template
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
-MAN1= perl2html.1 pods2html.1 \
- podtree2html.1
+MAN1= mod2html.1 perl2html.1 pods2html.1 podtree2html.1
MAN3= Pod::Tree.3 \
Pod::Tree::HTML.3 \
Pod::Tree::Node.3 \
@@ -42,4 +41,10 @@ post-patch:
${REINPLACE_CMD} -e '/pod2html/d' ${WRKSRC}/MANIFEST
${RM} ${WRKSRC}/t/pod2html.t
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-Pod-Escapes>=1.02:${PORTSDIR}/textproc/p5-Pod-Escapes
+.endif
+
+.include <bsd.port.post.mk>