aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-RTF-Tokenizer
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2003-10-17 07:46:55 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2003-10-17 07:46:55 +0000
commit5a2d1fa3ef5f1666b87b254d5abd66bc7be89e8c (patch)
treeb286d3e797d57e619f0be36e6a0a3c1f3c088267 /textproc/p5-RTF-Tokenizer
parentb8896a3ccd8a1ee6c72136e604a45e34db9757ce (diff)
downloadports-5a2d1fa3ef5f1666b87b254d5abd66bc7be89e8c.tar.gz
ports-5a2d1fa3ef5f1666b87b254d5abd66bc7be89e8c.zip
Notes
Diffstat (limited to 'textproc/p5-RTF-Tokenizer')
-rw-r--r--textproc/p5-RTF-Tokenizer/Makefile22
-rw-r--r--textproc/p5-RTF-Tokenizer/distinfo1
-rw-r--r--textproc/p5-RTF-Tokenizer/pkg-descr13
-rw-r--r--textproc/p5-RTF-Tokenizer/pkg-plist7
4 files changed, 43 insertions, 0 deletions
diff --git a/textproc/p5-RTF-Tokenizer/Makefile b/textproc/p5-RTF-Tokenizer/Makefile
new file mode 100644
index 000000000000..cc9501416b77
--- /dev/null
+++ b/textproc/p5-RTF-Tokenizer/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: textproc/p5-RTF-Tokenizer
+# Date created: Oct 15th 2003
+# Whom: clsung@dragon2.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= RTF-Tokenizer
+PORTVERSION= 1.04
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= RTF
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= Perl module for reading RTF files
+
+PERL_CONFIGURE= yes
+
+MAN3= RTF::Tokenizer.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-RTF-Tokenizer/distinfo b/textproc/p5-RTF-Tokenizer/distinfo
new file mode 100644
index 000000000000..01d7f8bb7674
--- /dev/null
+++ b/textproc/p5-RTF-Tokenizer/distinfo
@@ -0,0 +1 @@
+MD5 (RTF-Tokenizer-1.04.tar.gz) = a2a211374c638dec34ebbd8fda91be3c
diff --git a/textproc/p5-RTF-Tokenizer/pkg-descr b/textproc/p5-RTF-Tokenizer/pkg-descr
new file mode 100644
index 000000000000..f940f4e3a673
--- /dev/null
+++ b/textproc/p5-RTF-Tokenizer/pkg-descr
@@ -0,0 +1,13 @@
+ RTF::Tokenizer is an object-orientated low-level RTF reader. If
+you're looking to render RTF, or want a higher-level RTF processor,
+this is not the module for you - you want RTF::Reader. This is the
+sixth release of RTF::Tokenizer - it's faster, higher quality, and
+implements the RTF standard better than any previous release.
+
+ It's also philosophically a better module, and conforms more
+strictly to Object Orientated guidelines - it can be sub-classed
+and the interface is cleaner.
+
+--
+Peter Sergeant
+rtft@clueball.com
diff --git a/textproc/p5-RTF-Tokenizer/pkg-plist b/textproc/p5-RTF-Tokenizer/pkg-plist
new file mode 100644
index 000000000000..67ff59031f69
--- /dev/null
+++ b/textproc/p5-RTF-Tokenizer/pkg-plist
@@ -0,0 +1,7 @@
+bin/rtfdiff
+bin/rtfdump
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/RTF/Tokenizer/.packlist
+%%SITE_PERL%%/RTF/Tokenizer.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/RTF/Tokenizer
+@dirrm %%SITE_PERL%%/RTF
+@unexec rmdir %D/%%SITE_PERL%%/RTF 2>/dev/null || true