aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Regexp-Copy
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2007-12-25 08:57:51 +0000
committerAndrej Zverev <az@FreeBSD.org>2007-12-25 08:57:51 +0000
commitdc4bbbce24394eba535e5709fa2ccac770efe6da (patch)
treedbe4071c2597cea91badc1c78ee6395f74aab57e /textproc/p5-Regexp-Copy
parenta903166d30e0e0244f988e256ab261beaf1a1ec7 (diff)
downloadports-dc4bbbce24394eba535e5709fa2ccac770efe6da.tar.gz
ports-dc4bbbce24394eba535e5709fa2ccac770efe6da.zip
Notes
Diffstat (limited to 'textproc/p5-Regexp-Copy')
-rw-r--r--textproc/p5-Regexp-Copy/Makefile25
-rw-r--r--textproc/p5-Regexp-Copy/distinfo3
-rw-r--r--textproc/p5-Regexp-Copy/pkg-descr9
-rw-r--r--textproc/p5-Regexp-Copy/pkg-plist10
4 files changed, 47 insertions, 0 deletions
diff --git a/textproc/p5-Regexp-Copy/Makefile b/textproc/p5-Regexp-Copy/Makefile
new file mode 100644
index 000000000000..8c7946194257
--- /dev/null
+++ b/textproc/p5-Regexp-Copy/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Regexp-Copy
+# Date created: 2007-12-24
+# Whom: Andrej Zverev <andrey.zverev@electro-com.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Regexp-Copy
+PORTVERSION= 0.06
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/J/JD/JDUNCAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A copy the contents of one Regexp object to another
+
+BUILD_DEPENDS= p5-ExtUtils-MakeMaker>=6.11:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Regexp::Copy.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Regexp-Copy/distinfo b/textproc/p5-Regexp-Copy/distinfo
new file mode 100644
index 000000000000..74d77a9ff7e9
--- /dev/null
+++ b/textproc/p5-Regexp-Copy/distinfo
@@ -0,0 +1,3 @@
+MD5 (Regexp-Copy-0.06.tar.gz) = d0f3875e0655c0ac9eb37813ec82c137
+SHA256 (Regexp-Copy-0.06.tar.gz) = 972beb7a88ebcdb76f33e64ee9e11dc3d550be22479067145546873bc8ea8825
+SIZE (Regexp-Copy-0.06.tar.gz) = 3104
diff --git a/textproc/p5-Regexp-Copy/pkg-descr b/textproc/p5-Regexp-Copy/pkg-descr
new file mode 100644
index 000000000000..ebca2a3472b4
--- /dev/null
+++ b/textproc/p5-Regexp-Copy/pkg-descr
@@ -0,0 +1,9 @@
+Regexp::Copy allows you to copy the contents of one Regexp object to another.
+A problem that I have found with the qr// operator is that the Regexp objects
+that it creates are is impossible to dereference.
+This causes problems if you want to change the data in the regexp without
+losing the reference to it. Its impossible.
+Regexp::Copy allows you to change the Regexp by copying one object created
+through qr// to another.
+
+WWW: http://search.cpan.org/~jduncan/
diff --git a/textproc/p5-Regexp-Copy/pkg-plist b/textproc/p5-Regexp-Copy/pkg-plist
new file mode 100644
index 000000000000..f6f8bde330cc
--- /dev/null
+++ b/textproc/p5-Regexp-Copy/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/Regexp/Storable.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Regexp/Copy.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp/Copy/Copy.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp/Copy/Copy.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp/Copy/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp/Copy/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp/Copy
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Regexp
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Regexp