aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-SGML-DTDParse/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-14 06:16:17 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-14 06:16:17 +0000
commit1cc7ffbe07b61c7270a780fc8c4869c37eb1bd66 (patch)
tree939543341f5fd63d15b285b561df5ccac132e21c /textproc/p5-SGML-DTDParse/Makefile
parent8d66f83145e3af14c139104ae6a91b811a8acc1c (diff)
downloadports-1cc7ffbe07b61c7270a780fc8c4869c37eb1bd66.tar.gz
ports-1cc7ffbe07b61c7270a780fc8c4869c37eb1bd66.zip
Notes
Diffstat (limited to 'textproc/p5-SGML-DTDParse/Makefile')
-rw-r--r--textproc/p5-SGML-DTDParse/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/textproc/p5-SGML-DTDParse/Makefile b/textproc/p5-SGML-DTDParse/Makefile
new file mode 100644
index 000000000000..7e0a2144af81
--- /dev/null
+++ b/textproc/p5-SGML-DTDParse/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-SGML-DTDParse
+# Date created: 2006/07/11
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SGML-DTDParse
+PORTVERSION= 2.00
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SGML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Parse an SGML or XML DTD
+
+BUILD_DEPENDS= p5-DelimMatch>=1.05:${PORTSDIR}/textproc/p5-DelimMatch \
+ p5-libxml>=0.08:${PORTSDIR}/textproc/p5-libxml \
+ p5-XML-DOM>=1.44:${PORTSDIR}/textproc/p5-XML-DOM \
+ p5-XML-Parser>=2.3:${PORTSDIR}/textproc/p5-XML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= dtddiff2html.1 dtdformat.1 dtddiff.1 dtdparse.1 dtdflatten.1
+MAN1PREFIX= ${PREFIX}
+MAN3= SGML::DTDParse::DTD.3 SGML::DTDParse.3 SGML::DTDParse::Util.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8 or later due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>