aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-SGML-DTDParse
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-14 06:16:17 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-14 06:16:17 +0000
commit1cc7ffbe07b61c7270a780fc8c4869c37eb1bd66 (patch)
tree939543341f5fd63d15b285b561df5ccac132e21c /textproc/p5-SGML-DTDParse
parent8d66f83145e3af14c139104ae6a91b811a8acc1c (diff)
downloadports-1cc7ffbe07b61c7270a780fc8c4869c37eb1bd66.tar.gz
ports-1cc7ffbe07b61c7270a780fc8c4869c37eb1bd66.zip
Notes
Diffstat (limited to 'textproc/p5-SGML-DTDParse')
-rw-r--r--textproc/p5-SGML-DTDParse/Makefile36
-rw-r--r--textproc/p5-SGML-DTDParse/distinfo3
-rw-r--r--textproc/p5-SGML-DTDParse/pkg-descr5
-rw-r--r--textproc/p5-SGML-DTDParse/pkg-plist20
4 files changed, 64 insertions, 0 deletions
diff --git a/textproc/p5-SGML-DTDParse/Makefile b/textproc/p5-SGML-DTDParse/Makefile
new file mode 100644
index 000000000000..7e0a2144af81
--- /dev/null
+++ b/textproc/p5-SGML-DTDParse/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-SGML-DTDParse
+# Date created: 2006/07/11
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SGML-DTDParse
+PORTVERSION= 2.00
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SGML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Parse an SGML or XML DTD
+
+BUILD_DEPENDS= p5-DelimMatch>=1.05:${PORTSDIR}/textproc/p5-DelimMatch \
+ p5-libxml>=0.08:${PORTSDIR}/textproc/p5-libxml \
+ p5-XML-DOM>=1.44:${PORTSDIR}/textproc/p5-XML-DOM \
+ p5-XML-Parser>=2.3:${PORTSDIR}/textproc/p5-XML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= dtddiff2html.1 dtdformat.1 dtddiff.1 dtdparse.1 dtdflatten.1
+MAN1PREFIX= ${PREFIX}
+MAN3= SGML::DTDParse::DTD.3 SGML::DTDParse.3 SGML::DTDParse::Util.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8 or later due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-SGML-DTDParse/distinfo b/textproc/p5-SGML-DTDParse/distinfo
new file mode 100644
index 000000000000..babe0de8f004
--- /dev/null
+++ b/textproc/p5-SGML-DTDParse/distinfo
@@ -0,0 +1,3 @@
+MD5 (SGML-DTDParse-2.00.tar.gz) = bcff0835a0a7480794311fa0821d4db9
+SHA256 (SGML-DTDParse-2.00.tar.gz) = 092734401d77d7a6693a1db5a1cc18b43c3671eb2d8ab52b34af6b9417dadde3
+SIZE (SGML-DTDParse-2.00.tar.gz) = 57846
diff --git a/textproc/p5-SGML-DTDParse/pkg-descr b/textproc/p5-SGML-DTDParse/pkg-descr
new file mode 100644
index 000000000000..2a55f876c165
--- /dev/null
+++ b/textproc/p5-SGML-DTDParse/pkg-descr
@@ -0,0 +1,5 @@
+The DTDParse collection is a set of Perl modules and scripts for
+manipulating SGML an XML Document Type Definitions (DTDs). DTDParse is
+designed primarily to aid in the understanding and documentation of DTDs.
+
+WWW: http://search.cpan.org/dist/SGML-DTDParse/
diff --git a/textproc/p5-SGML-DTDParse/pkg-plist b/textproc/p5-SGML-DTDParse/pkg-plist
new file mode 100644
index 000000000000..7bde1fed8b75
--- /dev/null
+++ b/textproc/p5-SGML-DTDParse/pkg-plist
@@ -0,0 +1,20 @@
+bin/dtddiff2html
+bin/dtdformat
+bin/dtddiff
+bin/dtdparse
+bin/dtdflatten
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SGML/DTDParse/.packlist
+%%SITE_PERL%%/SGML/DTDParse.pm
+%%SITE_PERL%%/SGML/DTDParse/Tokenizer.pm
+%%SITE_PERL%%/SGML/DTDParse/DTD.pm
+%%SITE_PERL%%/SGML/DTDParse/Util.pm
+%%SITE_PERL%%/SGML/DTDParse/ContentModel.pm
+%%SITE_PERL%%/SGML/DTDParse/Catalog.pm
+%%SITE_PERL%%/SGML/DTDParse/Format/plain.pl
+%%SITE_PERL%%/SGML/DTDParse/Format/refentry.pl
+%%SITE_PERL%%/SGML/DTDParse/Format/html.pl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SGML/DTDParse
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SGML
+@dirrmtry %%SITE_PERL%%/SGML/DTDParse/Format
+@dirrmtry %%SITE_PERL%%/SGML/DTDParse
+@dirrmtry %%SITE_PERL%%/SGML