aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-SVG-Parser
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-29 01:48:26 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-29 01:48:26 +0000
commit8318c72e2ca9e747ef329b35f269bf8b72ed5dba (patch)
treef8fe6b2b58afc749a7940082bdf0de405228a8c8 /textproc/p5-SVG-Parser
parent0fb19bb36b5aab972943c2559c2c6b24b8a6ee16 (diff)
downloadports-8318c72e2ca9e747ef329b35f269bf8b72ed5dba.tar.gz
ports-8318c72e2ca9e747ef329b35f269bf8b72ed5dba.zip
Notes
Diffstat (limited to 'textproc/p5-SVG-Parser')
-rw-r--r--textproc/p5-SVG-Parser/Makefile31
-rw-r--r--textproc/p5-SVG-Parser/distinfo2
-rw-r--r--textproc/p5-SVG-Parser/pkg-descr14
-rw-r--r--textproc/p5-SVG-Parser/pkg-plist8
4 files changed, 55 insertions, 0 deletions
diff --git a/textproc/p5-SVG-Parser/Makefile b/textproc/p5-SVG-Parser/Makefile
new file mode 100644
index 000000000000..788cabaca986
--- /dev/null
+++ b/textproc/p5-SVG-Parser/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-SVG-Parser
+# Date created: 2011-09-29
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVG-Parser
+PORTVERSION= 1.03
+CATEGORIES= textproc graphics perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= XML Parser for SVG documents
+
+BUILD_DEPENDS= p5-SVG>=2:${PORTSDIR}/textproc/p5-SVG \
+ p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-XML-SAX>=0:${PORTSDIR}/textproc/p5-XML-SAX
+RUN_DEPENDS= p5-SVG>=2:${PORTSDIR}/textproc/p5-SVG \
+ p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-XML-SAX>=0:${PORTSDIR}/textproc/p5-XML-SAX
+
+PERL_MODBUILD= yes
+
+MAN3= SVG::Parser.3 \
+ SVG::Parser::Expat.3 \
+ SVG::Parser::SAX.3 \
+ SVG::Parser::SAX::Handler.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-SVG-Parser/distinfo b/textproc/p5-SVG-Parser/distinfo
new file mode 100644
index 000000000000..50c1f759348b
--- /dev/null
+++ b/textproc/p5-SVG-Parser/distinfo
@@ -0,0 +1,2 @@
+SHA256 (SVG-Parser-1.03.tar.gz) = 6c8c9117795f240cfe33a8e8345a0f7f220f89e259a604f148d204c7758cfbe1
+SIZE (SVG-Parser-1.03.tar.gz) = 15304
diff --git a/textproc/p5-SVG-Parser/pkg-descr b/textproc/p5-SVG-Parser/pkg-descr
new file mode 100644
index 000000000000..917ed1ab752b
--- /dev/null
+++ b/textproc/p5-SVG-Parser/pkg-descr
@@ -0,0 +1,14 @@
+SVG::Parser is an XML parser for SVG Documents. It takes XML as input and
+produces an SVG object as its output.
+
+SVG::Parser supports both XML::SAX and XML::Parser (Expat) parsers, with SAX
+preferred by default. Only one of these needs to be installed for SVG::Parser to
+function.
+
+A list of preferred parsers may be specified in the import list - SVG::Parser
+will use the first parser that successfully loads. Some basic measures are taken
+to provide cross-compatability. Applications requiring more advanced parser
+features should use the relevant parser module directly; see SVG::Parser::Expat
+and SVG::Parser::SAX.
+
+WWW: http://search.cpan.org/dist/SVG-Parser/
diff --git a/textproc/p5-SVG-Parser/pkg-plist b/textproc/p5-SVG-Parser/pkg-plist
new file mode 100644
index 000000000000..7d87c233c7d3
--- /dev/null
+++ b/textproc/p5-SVG-Parser/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/SVG/Parser.pm
+%%SITE_PERL%%/SVG/Parser/Base.pm
+%%SITE_PERL%%/SVG/Parser/Expat.pm
+%%SITE_PERL%%/SVG/Parser/SAX.pm
+%%SITE_PERL%%/SVG/Parser/SAX/Handler.pm
+@dirrm %%SITE_PERL%%/SVG/Parser/SAX
+@dirrm %%SITE_PERL%%/SVG/Parser
+@dirrmtry %%SITE_PERL%%/SVG