aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Search-Elasticsearch-Client-5_0/Makefile
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2019-07-23 17:43:24 +0000
committerDan Langille <dvl@FreeBSD.org>2019-07-23 17:43:24 +0000
commitf6b355eaf0205d5c08d180df9aee841a57c87d3f (patch)
treeb3f95b5d06b6bd77a230888a70022cd02892af84 /textproc/p5-Search-Elasticsearch-Client-5_0/Makefile
parent1c93a451b74ef2dbae0cf576384a754aa7204d73 (diff)
Notes
Diffstat (limited to 'textproc/p5-Search-Elasticsearch-Client-5_0/Makefile')
-rw-r--r--textproc/p5-Search-Elasticsearch-Client-5_0/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/p5-Search-Elasticsearch-Client-5_0/Makefile b/textproc/p5-Search-Elasticsearch-Client-5_0/Makefile
new file mode 100644
index 000000000000..240ff2325999
--- /dev/null
+++ b/textproc/p5-Search-Elasticsearch-Client-5_0/Makefile
@@ -0,0 +1,31 @@
+# Created by: Dan Langille <dvl@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Search-Elasticsearch-Client-5_0
+PORTVERSION= 6.00
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DRTECH
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= elastic@FreeBSD.org
+COMMENT= ElasticSearch API for 5.0 servers
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Search-Elasticsearch>=5.01:textproc/p5-Search-Elasticsearch \
+ p5-Devel-GlobalDestruction>=0:devel/p5-Devel-GlobalDestruction \
+ p5-Moo>=1.003:devel/p5-Moo \
+ p5-Try-Tiny>=0:lang/p5-Try-Tiny \
+ p5-namespace-clean>=0:devel/p5-namespace-clean
+TEST_DEPENDS= p5-IO-Socket-SSL>=0:security/p5-IO-Socket-SSL \
+ p5-JSON-XS>=0:converters/p5-JSON-XS \
+ p5-Log-Any-Adapter-Callback>=0:devel/p5-Log-Any-Adapter-Callback \
+ p5-Test-Deep>=0:devel/p5-Test-Deep \
+ p5-Test-Exception>=0:devel/p5-Test-Exception
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>