aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Search-Odeum
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-07-30 02:24:17 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-07-30 02:24:17 +0000
commit584dbd30382f702effe7095f825665ec2bb0ef05 (patch)
tree89f8d7adb8e6bb0df6f3d970e29b3d06e2af307f /textproc/p5-Search-Odeum
parentc263bb1b8423b6965273e2f10a3c2bf6e42cd7d1 (diff)
downloadports-584dbd30382f702effe7095f825665ec2bb0ef05.tar.gz
ports-584dbd30382f702effe7095f825665ec2bb0ef05.zip
Notes
Diffstat (limited to 'textproc/p5-Search-Odeum')
-rw-r--r--textproc/p5-Search-Odeum/Makefile28
-rw-r--r--textproc/p5-Search-Odeum/distinfo3
-rw-r--r--textproc/p5-Search-Odeum/pkg-descr4
-rw-r--r--textproc/p5-Search-Odeum/pkg-plist11
4 files changed, 46 insertions, 0 deletions
diff --git a/textproc/p5-Search-Odeum/Makefile b/textproc/p5-Search-Odeum/Makefile
new file mode 100644
index 000000000000..33e6d25f7ace
--- /dev/null
+++ b/textproc/p5-Search-Odeum/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Search-Odeum
+# Date created: 2007-07-26
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Search-Odeum
+PORTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Search
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl interface to the Odeum inverted index API
+
+LIB_DEPENDS= qdbm:${PORTSDIR}/databases/qdbm
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= CFLAGS="${CFLAGS}"
+PERL_CONFIGURE= yes
+
+MAN3= Search::Odeum.3 \
+ Search::Odeum::Document.3 \
+ Search::Odeum::Result.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Search-Odeum/distinfo b/textproc/p5-Search-Odeum/distinfo
new file mode 100644
index 000000000000..abf022849de8
--- /dev/null
+++ b/textproc/p5-Search-Odeum/distinfo
@@ -0,0 +1,3 @@
+MD5 (Search-Odeum-0.02.tar.gz) = 52fe4b7d73a557b1cd7953f268c01980
+SHA256 (Search-Odeum-0.02.tar.gz) = 34d5784bc45afa3811d7c8f96ef1b60f93ae1624a5864e8e1b40dd115a565f6c
+SIZE (Search-Odeum-0.02.tar.gz) = 36293
diff --git a/textproc/p5-Search-Odeum/pkg-descr b/textproc/p5-Search-Odeum/pkg-descr
new file mode 100644
index 000000000000..8f066c445a8c
--- /dev/null
+++ b/textproc/p5-Search-Odeum/pkg-descr
@@ -0,0 +1,4 @@
+Search::Odeum is an interface to the Odeum API. Odeum is the inverted
+index API which is a part of qdbm database library.
+
+WWW: http://search.cpan.org/dist/Search-Odeum/
diff --git a/textproc/p5-Search-Odeum/pkg-plist b/textproc/p5-Search-Odeum/pkg-plist
new file mode 100644
index 000000000000..ca0e83108039
--- /dev/null
+++ b/textproc/p5-Search-Odeum/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/Search/Odeum.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Search/Odeum/Document.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Search/Odeum/Result.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/Odeum/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/Odeum/Odeum.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/Odeum/Odeum.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/Odeum
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Search/Odeum
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Search