aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Solr
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-15 19:41:56 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-15 19:41:56 +0000
commit419a983bfbebaae6170a304593590d28a4daebfd (patch)
treeb8badcaf339e6738848a710e997f6d0ced30a4df /textproc/p5-Solr
parentf9998268e7e6f3310adb8c503524c5cdb6b62c3e (diff)
downloadports-419a983bfbebaae6170a304593590d28a4daebfd.tar.gz
ports-419a983bfbebaae6170a304593590d28a4daebfd.zip
This module provides a set of methods for adding (updating) and
deleting entries in an existing solr server. WWW: http://search.cpan.org/dist/Solr/ PR: ports/132666 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=230156
Diffstat (limited to 'textproc/p5-Solr')
-rw-r--r--textproc/p5-Solr/Makefile28
-rw-r--r--textproc/p5-Solr/distinfo3
-rw-r--r--textproc/p5-Solr/pkg-descr4
-rw-r--r--textproc/p5-Solr/pkg-plist7
4 files changed, 42 insertions, 0 deletions
diff --git a/textproc/p5-Solr/Makefile b/textproc/p5-Solr/Makefile
new file mode 100644
index 000000000000..84fefae8e82e
--- /dev/null
+++ b/textproc/p5-Solr/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Solr
+# Date created: 2009-03-16
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Solr
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/G/GA/GARAFOLA/Solr
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl extension for interfacing with Solr
+
+RUN_DEPENDS= p5-File-Slurp>0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-Log-Log4perl>0:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-XML-Simple>0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN3= Solr.3 Solr::HTTPUpdateHandler.3 Solr::Schema.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Solr/distinfo b/textproc/p5-Solr/distinfo
new file mode 100644
index 000000000000..21ac072700e4
--- /dev/null
+++ b/textproc/p5-Solr/distinfo
@@ -0,0 +1,3 @@
+MD5 (Solr-0.03.tar.gz) = 5fa1861ccf0721c7c2cd67c1798ad207
+SHA256 (Solr-0.03.tar.gz) = daddc72b122e3bec90ddda6d8bc68fa17f817db65163d67052dc5b0eded4da4c
+SIZE (Solr-0.03.tar.gz) = 7731
diff --git a/textproc/p5-Solr/pkg-descr b/textproc/p5-Solr/pkg-descr
new file mode 100644
index 000000000000..5fbb0d1f4386
--- /dev/null
+++ b/textproc/p5-Solr/pkg-descr
@@ -0,0 +1,4 @@
+This module provides a set of methods for adding (updating) and
+deleting entries in an existing solr server.
+
+WWW: http://search.cpan.org/dist/Solr/
diff --git a/textproc/p5-Solr/pkg-plist b/textproc/p5-Solr/pkg-plist
new file mode 100644
index 000000000000..80fd14813928
--- /dev/null
+++ b/textproc/p5-Solr/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Solr/.packlist
+%%SITE_PERL%%/Solr.pm
+%%SITE_PERL%%/Solr/HTTPUpdateHandler.pm
+%%SITE_PERL%%/Solr/Schema.pm
+@dirrmtry %%SITE_PERL%%/Solr
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Solr