aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Spork/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-07-18 06:48:14 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-07-18 06:48:14 +0000
commit9427ab710d604666b5b201067e6b9cf355514489 (patch)
treed758700f583acb689661008dd2afa059c3576676 /textproc/p5-Spork/Makefile
parent7c956ef4d4b956ae575e175561abf3158e7cac7c (diff)
downloadports-9427ab710d604666b5b201067e6b9cf355514489.tar.gz
ports-9427ab710d604666b5b201067e6b9cf355514489.zip
Notes
Diffstat (limited to 'textproc/p5-Spork/Makefile')
-rw-r--r--textproc/p5-Spork/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/textproc/p5-Spork/Makefile b/textproc/p5-Spork/Makefile
new file mode 100644
index 000000000000..e33356789376
--- /dev/null
+++ b/textproc/p5-Spork/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Spork
+# Date created: 2004-07-18
+# Whom: Elvis Chiang <elvis@sslab.cs.ccu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Spork
+PORTVERSION= 0.18
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/I/IN/INGY/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= elvis@sslab.cs.ccu.edu.tw
+COMMENT= Creating standalone HTML slideshows from Kwiki markup
+
+BUILD_DEPENDS= ${SITE_PERL}/Kwiki.pm:${PORTSDIR}/www/p5-Kwiki
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= spork.1
+MAN3= Spork.3 Spork::Config.3
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.1 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>