aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Spreadsheet-Read
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-04-02 16:24:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-04-02 16:24:25 +0000
commit4748a5a1730d442e4fdd89ad701b4c83509e4409 (patch)
treec8b91d3dfe8055603ff54aedec7082122be09155 /textproc/p5-Spreadsheet-Read
parent0f7e18517210ebe2398da4cdb3e7ee8e3f5d4e0c (diff)
downloadports-4748a5a1730d442e4fdd89ad701b4c83509e4409.tar.gz
ports-4748a5a1730d442e4fdd89ad701b4c83509e4409.zip
Notes
Diffstat (limited to 'textproc/p5-Spreadsheet-Read')
-rw-r--r--textproc/p5-Spreadsheet-Read/Makefile36
-rw-r--r--textproc/p5-Spreadsheet-Read/distinfo3
-rw-r--r--textproc/p5-Spreadsheet-Read/pkg-descr3
-rw-r--r--textproc/p5-Spreadsheet-Read/pkg-plist5
4 files changed, 47 insertions, 0 deletions
diff --git a/textproc/p5-Spreadsheet-Read/Makefile b/textproc/p5-Spreadsheet-Read/Makefile
new file mode 100644
index 000000000000..d77bd4bd4002
--- /dev/null
+++ b/textproc/p5-Spreadsheet-Read/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Spreadsheet-Read
+# Date created: 2010-03-08
+# Whom: Steve Wills <steve@mouf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Spreadsheet-Read
+PORTVERSION= 0.38
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/H/HM/HMBRAND
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= steve@mouf.net
+COMMENT= Read the data from a spreadsheet
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/Stringy.pm:${PORTSDIR}/devel/p5-IO-stringy \
+ ${SITE_PERL}/mach/Text/CSV_XS.pm:${PORTSDIR}/textproc/p5-Text-CSV_XS \
+ ${SITE_PERL}/Text/CSV.pm:${PORTSDIR}/textproc/p5-Text-CSV \
+ ${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings \
+ ${SITE_PERL}/Spreadsheet/ReadSXC.pm:${PORTSDIR}/textproc/p5-Spreadsheet-ReadSXC \
+ ${SITE_PERL}/Spreadsheet/ParseExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-ParseExcel
+RUN_DEPENDS= ${SITE_PERL}/IO/Stringy.pm:${PORTSDIR}/devel/p5-IO-stringy \
+ ${SITE_PERL}/mach/Text/CSV_XS.pm:${PORTSDIR}/textproc/p5-Text-CSV_XS \
+ ${SITE_PERL}/Text/CSV.pm:${PORTSDIR}/textproc/p5-Text-CSV \
+ ${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings \
+ ${SITE_PERL}/Spreadsheet/ReadSXC.pm:${PORTSDIR}/textproc/p5-Spreadsheet-ReadSXC \
+ ${SITE_PERL}/Spreadsheet/ParseExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-ParseExcel
+
+PERL_CONFIGURE= yes
+
+MAN3= Spreadsheet::Read.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Spreadsheet-Read/distinfo b/textproc/p5-Spreadsheet-Read/distinfo
new file mode 100644
index 000000000000..4077e6c2aced
--- /dev/null
+++ b/textproc/p5-Spreadsheet-Read/distinfo
@@ -0,0 +1,3 @@
+MD5 (Spreadsheet-Read-0.38.tgz) = 57f1a1c2e8999369bec4cc85b62ec7e6
+SHA256 (Spreadsheet-Read-0.38.tgz) = e1d34ecaa00886d947776af79008519b2119db79d15b63400edc1f8df157160a
+SIZE (Spreadsheet-Read-0.38.tgz) = 120616
diff --git a/textproc/p5-Spreadsheet-Read/pkg-descr b/textproc/p5-Spreadsheet-Read/pkg-descr
new file mode 100644
index 000000000000..0aaa0f155c79
--- /dev/null
+++ b/textproc/p5-Spreadsheet-Read/pkg-descr
@@ -0,0 +1,3 @@
+Read the data from a spreadsheet
+
+WWW: http://search.cpan.org/dist/Spreadsheet-Read/
diff --git a/textproc/p5-Spreadsheet-Read/pkg-plist b/textproc/p5-Spreadsheet-Read/pkg-plist
new file mode 100644
index 000000000000..ed3353a8a6da
--- /dev/null
+++ b/textproc/p5-Spreadsheet-Read/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/mach/auto/Spreadsheet/Read/.packlist
+%%SITE_PERL%%/Spreadsheet/Read.pm
+@dirrmtry %%SITE_PERL%%/Spreadsheet
+@dirrmtry %%SITE_PERL%%/mach/auto/Spreadsheet/Read
+@dirrmtry %%SITE_PERL%%/mach/auto/Spreadsheet