aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Spreadsheet-XLSX
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-08-12 16:11:39 +0000
committerSteve Wills <swills@FreeBSD.org>2011-08-12 16:11:39 +0000
commit5ce5df4d841ba31fb30590f12a804d4f0f97248f (patch)
tree5fbedb94808c5bd6cf92d067a3677d9b60db65e0 /textproc/p5-Spreadsheet-XLSX
parentd423cdc65026010d1d2dd5bc45cd6bb5560298a5 (diff)
Notes
Diffstat (limited to 'textproc/p5-Spreadsheet-XLSX')
-rw-r--r--textproc/p5-Spreadsheet-XLSX/Makefile29
-rw-r--r--textproc/p5-Spreadsheet-XLSX/distinfo2
-rw-r--r--textproc/p5-Spreadsheet-XLSX/pkg-descr6
-rw-r--r--textproc/p5-Spreadsheet-XLSX/pkg-plist6
4 files changed, 43 insertions, 0 deletions
diff --git a/textproc/p5-Spreadsheet-XLSX/Makefile b/textproc/p5-Spreadsheet-XLSX/Makefile
new file mode 100644
index 000000000000..95dd39052b6b
--- /dev/null
+++ b/textproc/p5-Spreadsheet-XLSX/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Spreadsheet-XLSX
+# Date created: 2011-08-12
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Spreadsheet-XLSX
+PORTVERSION= 0.13
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/D/DM/DMOW
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-withoutworldwriteables
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Perl extension for reading MS Excel 2007 files
+
+BUILD_DEPENDS= p5-Spreadsheet-ParseExcel>0:${PORTSDIR}/textproc/p5-Spreadsheet-ParseExcel \
+ p5-Archive-Zip>0:${PORTSDIR}/archivers/p5-Archive-Zip
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PERL_CONFIGURE= yes
+
+MAN3= Spreadsheet::XLSX.3 Spreadsheet::XLSX::Fmt2007.3 Spreadsheet::XLSX::Utility2007.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Spreadsheet-XLSX/distinfo b/textproc/p5-Spreadsheet-XLSX/distinfo
new file mode 100644
index 000000000000..863162df1c44
--- /dev/null
+++ b/textproc/p5-Spreadsheet-XLSX/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Spreadsheet-XLSX-0.13-withoutworldwriteables.tar.gz) = 63a63b6eebb59c941c5394cc087748e9219c57055f8cfc2eaa7c3939a1e67be5
+SIZE (Spreadsheet-XLSX-0.13-withoutworldwriteables.tar.gz) = 50308
diff --git a/textproc/p5-Spreadsheet-XLSX/pkg-descr b/textproc/p5-Spreadsheet-XLSX/pkg-descr
new file mode 100644
index 000000000000..be2534c5724b
--- /dev/null
+++ b/textproc/p5-Spreadsheet-XLSX/pkg-descr
@@ -0,0 +1,6 @@
+This Perl module is a emulation of Spreadsheet::ParseExcel for Excel 2007
+(.xlsx) file format. It supports styles and many of Excel's quirks, but not
+all. It populates the classes from Spreadsheet::ParseExcel for
+interoperability; including Workbook, Worksheet, and Cell.
+
+WWW: http://search.cpan.org/dist/Spreadsheet-XLSX
diff --git a/textproc/p5-Spreadsheet-XLSX/pkg-plist b/textproc/p5-Spreadsheet-XLSX/pkg-plist
new file mode 100644
index 000000000000..0acfc27184bb
--- /dev/null
+++ b/textproc/p5-Spreadsheet-XLSX/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Spreadsheet/XLSX/Utility2007.pm
+%%SITE_PERL%%/Spreadsheet/XLSX/Fmt2007.pm
+%%SITE_PERL%%/Spreadsheet/XLSX.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spreadsheet/XLSX/.packlist
+@dirrmtry %%SITE_PERL%%/Spreadsheet/XLSX
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Spreadsheet/XLSX