aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-String-Flogger/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2010-12-03 19:53:54 +0000
committerAnton Berezin <tobez@FreeBSD.org>2010-12-03 19:53:54 +0000
commita35b82c608560dcf25fd0929d33186e016406137 (patch)
tree4c76789d3616fe4dd332b003515d8fe8d72ce7a3 /textproc/p5-String-Flogger/Makefile
parenteba4de052c6efc2a8aadb170e40fa4885dacce69 (diff)
downloadports-a35b82c608560dcf25fd0929d33186e016406137.tar.gz
ports-a35b82c608560dcf25fd0929d33186e016406137.zip
Notes
Diffstat (limited to 'textproc/p5-String-Flogger/Makefile')
-rw-r--r--textproc/p5-String-Flogger/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/p5-String-Flogger/Makefile b/textproc/p5-String-Flogger/Makefile
new file mode 100644
index 000000000000..b6794bca726d
--- /dev/null
+++ b/textproc/p5-String-Flogger/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: textproc/p5-String-Flogger
+# Date created: 03 December 2010
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-Flogger
+PORTVERSION= 1.101240
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= String
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= String munging for loggers
+
+BUILD_DEPENDS= p5-Params-Util>0:${PORTSDIR}/devel/p5-Params-Util \
+ p5-Sub-Exporter>0:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-JSON>0:${PORTSDIR}/converters/p5-JSON
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= String::Flogger.3
+
+.include <bsd.port.mk>