aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-String-Flogger
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2010-12-03 19:53:54 +0000
committerAnton Berezin <tobez@FreeBSD.org>2010-12-03 19:53:54 +0000
commita35b82c608560dcf25fd0929d33186e016406137 (patch)
tree4c76789d3616fe4dd332b003515d8fe8d72ce7a3 /textproc/p5-String-Flogger
parenteba4de052c6efc2a8aadb170e40fa4885dacce69 (diff)
downloadports-a35b82c608560dcf25fd0929d33186e016406137.tar.gz
ports-a35b82c608560dcf25fd0929d33186e016406137.zip
Notes
Diffstat (limited to 'textproc/p5-String-Flogger')
-rw-r--r--textproc/p5-String-Flogger/Makefile27
-rw-r--r--textproc/p5-String-Flogger/distinfo2
-rw-r--r--textproc/p5-String-Flogger/pkg-descr6
-rw-r--r--textproc/p5-String-Flogger/pkg-plist5
4 files changed, 40 insertions, 0 deletions
diff --git a/textproc/p5-String-Flogger/Makefile b/textproc/p5-String-Flogger/Makefile
new file mode 100644
index 000000000000..b6794bca726d
--- /dev/null
+++ b/textproc/p5-String-Flogger/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: textproc/p5-String-Flogger
+# Date created: 03 December 2010
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-Flogger
+PORTVERSION= 1.101240
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= String
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= String munging for loggers
+
+BUILD_DEPENDS= p5-Params-Util>0:${PORTSDIR}/devel/p5-Params-Util \
+ p5-Sub-Exporter>0:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-JSON>0:${PORTSDIR}/converters/p5-JSON
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= String::Flogger.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-String-Flogger/distinfo b/textproc/p5-String-Flogger/distinfo
new file mode 100644
index 000000000000..77d07b0daf57
--- /dev/null
+++ b/textproc/p5-String-Flogger/distinfo
@@ -0,0 +1,2 @@
+SHA256 (String-Flogger-1.101240.tar.gz) = 4d5d26a479b68baa1dd1e1f28f1dc772400ecbe8639d2b8e71f1de2206557229
+SIZE (String-Flogger-1.101240.tar.gz) = 10497
diff --git a/textproc/p5-String-Flogger/pkg-descr b/textproc/p5-String-Flogger/pkg-descr
new file mode 100644
index 000000000000..2e1af96115d1
--- /dev/null
+++ b/textproc/p5-String-Flogger/pkg-descr
@@ -0,0 +1,6 @@
+String::Flogger::flog() args are mostly just like sprintf arguments, but
+non-strings (like references, objects, and undef) are converted to JSON,
+and we can defer evaluation of bits of the message so that it won't be
+evaluated unless needed.
+
+WWW: http://search.cpan.org/dist/String-Flogger/
diff --git a/textproc/p5-String-Flogger/pkg-plist b/textproc/p5-String-Flogger/pkg-plist
new file mode 100644
index 000000000000..f034a75ae105
--- /dev/null
+++ b/textproc/p5-String-Flogger/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/String/Flogger.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Flogger/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Flogger
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String
+@dirrmtry %%SITE_PERL%%/String