aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-String-Scanf
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-11-05 12:51:58 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-11-05 12:51:58 +0000
commitb658f568db298d10d9bf098289db9aa091747e51 (patch)
tree81dbe1788209179970e6aecf1123ca9990375db2 /textproc/p5-String-Scanf
parentb324f489eb4991887f749c66603b732eaea38beb (diff)
downloadports-b658f568db298d10d9bf098289db9aa091747e51.tar.gz
ports-b658f568db298d10d9bf098289db9aa091747e51.zip
Notes
Diffstat (limited to 'textproc/p5-String-Scanf')
-rw-r--r--textproc/p5-String-Scanf/Makefile22
-rw-r--r--textproc/p5-String-Scanf/distinfo1
-rw-r--r--textproc/p5-String-Scanf/pkg-comment1
-rw-r--r--textproc/p5-String-Scanf/pkg-descr7
-rw-r--r--textproc/p5-String-Scanf/pkg-plist5
5 files changed, 36 insertions, 0 deletions
diff --git a/textproc/p5-String-Scanf/Makefile b/textproc/p5-String-Scanf/Makefile
new file mode 100644
index 000000000000..0efb87145f10
--- /dev/null
+++ b/textproc/p5-String-Scanf/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: String::Scanf
+# Date created: 04 Nov 2001
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-Scanf
+PORTVERSION= 1.4
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= String
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+PERL_CONFIGURE= yes
+
+MAN3= String::Scanf.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-String-Scanf/distinfo b/textproc/p5-String-Scanf/distinfo
new file mode 100644
index 000000000000..0e11f856f834
--- /dev/null
+++ b/textproc/p5-String-Scanf/distinfo
@@ -0,0 +1 @@
+MD5 (String-Scanf-1.4.tar.gz) = 78dddf15428d109d2b61fcc9839bdaf6
diff --git a/textproc/p5-String-Scanf/pkg-comment b/textproc/p5-String-Scanf/pkg-comment
new file mode 100644
index 000000000000..5b4c46136b7e
--- /dev/null
+++ b/textproc/p5-String-Scanf/pkg-comment
@@ -0,0 +1 @@
+Emulates the sscanf() of the C stdio library
diff --git a/textproc/p5-String-Scanf/pkg-descr b/textproc/p5-String-Scanf/pkg-descr
new file mode 100644
index 000000000000..9edbf201e026
--- /dev/null
+++ b/textproc/p5-String-Scanf/pkg-descr
@@ -0,0 +1,7 @@
+Perl sscanf() can be used very much like the C stdio sscanf(), for detailed
+sscanf() documentation please refer to your usual documentation resources.
+The supported formats are: [diuoxefgsc] and the character class [].
+
+WWW: http://iki.fi/jhi/
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/textproc/p5-String-Scanf/pkg-plist b/textproc/p5-String-Scanf/pkg-plist
new file mode 100644
index 000000000000..b20d3ce3216d
--- /dev/null
+++ b/textproc/p5-String-Scanf/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/String/Scanf/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/String/Scanf.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/String/Scanf
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/String 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/String 2>/dev/null || true