aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Template-Declare/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2007-04-23 08:49:09 +0000
committerAnton Berezin <tobez@FreeBSD.org>2007-04-23 08:49:09 +0000
commit6086d86ea5290f901ddf390d443d7635a2de36c7 (patch)
tree0ccf2187ae2426ab90c6371184455719def1afc3 /textproc/p5-Template-Declare/Makefile
parentf3b494a0ca45be27c078c7525876daf874be1403 (diff)
downloadports-6086d86ea5290f901ddf390d443d7635a2de36c7.tar.gz
ports-6086d86ea5290f901ddf390d443d7635a2de36c7.zip
Notes
Diffstat (limited to 'textproc/p5-Template-Declare/Makefile')
-rw-r--r--textproc/p5-Template-Declare/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/textproc/p5-Template-Declare/Makefile b/textproc/p5-Template-Declare/Makefile
new file mode 100644
index 000000000000..59bc015cd686
--- /dev/null
+++ b/textproc/p5-Template-Declare/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: textproc/p5-Template-Declare
+# Date created: 23 April 2007
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Declare
+PORTVERSION= 0.07
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Template
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Perlish declarative templates
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Warn.pm:${PORTSDIR}/devel/p5-Test-Warn \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/HTML/Lint.pm:${PORTSDIR}/www/p5-HTML-Lint
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Template::Declare.3 \
+ Template::Declare::Tags.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= fails tests on this version of perl
+.endif
+
+.include <bsd.port.post.mk>