aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Template-Declare
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2007-04-23 08:49:09 +0000
committerAnton Berezin <tobez@FreeBSD.org>2007-04-23 08:49:09 +0000
commit6086d86ea5290f901ddf390d443d7635a2de36c7 (patch)
tree0ccf2187ae2426ab90c6371184455719def1afc3 /textproc/p5-Template-Declare
parentf3b494a0ca45be27c078c7525876daf874be1403 (diff)
downloadports-6086d86ea5290f901ddf390d443d7635a2de36c7.tar.gz
ports-6086d86ea5290f901ddf390d443d7635a2de36c7.zip
Notes
Diffstat (limited to 'textproc/p5-Template-Declare')
-rw-r--r--textproc/p5-Template-Declare/Makefile35
-rw-r--r--textproc/p5-Template-Declare/distinfo3
-rw-r--r--textproc/p5-Template-Declare/pkg-descr11
-rw-r--r--textproc/p5-Template-Declare/pkg-plist8
4 files changed, 57 insertions, 0 deletions
diff --git a/textproc/p5-Template-Declare/Makefile b/textproc/p5-Template-Declare/Makefile
new file mode 100644
index 000000000000..59bc015cd686
--- /dev/null
+++ b/textproc/p5-Template-Declare/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: textproc/p5-Template-Declare
+# Date created: 23 April 2007
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Declare
+PORTVERSION= 0.07
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Template
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Perlish declarative templates
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Warn.pm:${PORTSDIR}/devel/p5-Test-Warn \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/HTML/Lint.pm:${PORTSDIR}/www/p5-HTML-Lint
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Template::Declare.3 \
+ Template::Declare::Tags.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= fails tests on this version of perl
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Template-Declare/distinfo b/textproc/p5-Template-Declare/distinfo
new file mode 100644
index 000000000000..575b088becbd
--- /dev/null
+++ b/textproc/p5-Template-Declare/distinfo
@@ -0,0 +1,3 @@
+MD5 (Template-Declare-0.07.tar.gz) = fc1c05e6544d1e5715cbbe264f34455c
+SHA256 (Template-Declare-0.07.tar.gz) = b1048ee7f09f12b526aa4b466e0cc7610a173284e1b0fdc21c1387fa5791f033
+SIZE (Template-Declare-0.07.tar.gz) = 30217
diff --git a/textproc/p5-Template-Declare/pkg-descr b/textproc/p5-Template-Declare/pkg-descr
new file mode 100644
index 000000000000..12538168247a
--- /dev/null
+++ b/textproc/p5-Template-Declare/pkg-descr
@@ -0,0 +1,11 @@
+Template::Declare is a pure-perl declarative HTML templating system.
+A few key features and buzzwords:
+
+- All templates are 100% pure perl code
+- Simple declarative syntax
+- No angle brackets
+- Mixins
+- Inheritance
+- Public and private templates
+
+WWW: http://search.cpan.org/dist/Template-Declare/
diff --git a/textproc/p5-Template-Declare/pkg-plist b/textproc/p5-Template-Declare/pkg-plist
new file mode 100644
index 000000000000..0df24587b688
--- /dev/null
+++ b/textproc/p5-Template-Declare/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Template/Declare.pm
+%%SITE_PERL%%/Template/Declare/Buffer.pm
+%%SITE_PERL%%/Template/Declare/Tags.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Declare/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Declare
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template
+@dirrmtry %%SITE_PERL%%/Template/Declare
+@dirrmtry %%SITE_PERL%%/Template