aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Template-Extract
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-11-09 14:17:08 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-11-09 14:17:08 +0000
commit7cc78f06e8acee57f80a516f27870470c5bcbef6 (patch)
tree41ecad6a79c36245f660357179135f3f45fd5552 /textproc/p5-Template-Extract
parentef13b0fad92ec0979b92b1d6adecc84d8d23bfd7 (diff)
downloadports-7cc78f06e8acee57f80a516f27870470c5bcbef6.tar.gz
ports-7cc78f06e8acee57f80a516f27870470c5bcbef6.zip
Notes
Diffstat (limited to 'textproc/p5-Template-Extract')
-rw-r--r--textproc/p5-Template-Extract/Makefile34
-rw-r--r--textproc/p5-Template-Extract/distinfo3
-rw-r--r--textproc/p5-Template-Extract/pkg-descr6
-rw-r--r--textproc/p5-Template-Extract/pkg-plist9
4 files changed, 52 insertions, 0 deletions
diff --git a/textproc/p5-Template-Extract/Makefile b/textproc/p5-Template-Extract/Makefile
new file mode 100644
index 000000000000..041f79fd21c4
--- /dev/null
+++ b/textproc/p5-Template-Extract/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: p5-Template-Extract
+# Date created: Nov 8, 2005
+# Whom: Ying-Chieh Liao <ijliao@csie.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Extract
+PORTVERSION= 0.40
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Template
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Use TT2 syntax to extract data from documents
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Template::Extract.3 \
+ Template::Extract::Compile.3 \
+ Template::Extract::Parser.3 \
+ Template::Extract::Run.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "Requires perl 5.6.x or higher"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Template-Extract/distinfo b/textproc/p5-Template-Extract/distinfo
new file mode 100644
index 000000000000..dcaeb05df9c1
--- /dev/null
+++ b/textproc/p5-Template-Extract/distinfo
@@ -0,0 +1,3 @@
+MD5 (Template-Extract-0.40.tar.gz) = 2d5adf6744d65f53d228652adcb2dc54
+SHA256 (Template-Extract-0.40.tar.gz) = 24e959a7a9b7b84739715e86767039906ff388625260987f2384c6e8fbf4e301
+SIZE (Template-Extract-0.40.tar.gz) = 27960
diff --git a/textproc/p5-Template-Extract/pkg-descr b/textproc/p5-Template-Extract/pkg-descr
new file mode 100644
index 000000000000..b4c692c02fe4
--- /dev/null
+++ b/textproc/p5-Template-Extract/pkg-descr
@@ -0,0 +1,6 @@
+This module adds template extraction functionality to the Template toolkit.
+It can take a rendered document and its template together, and get the
+original data structure back, effectively reversing the Template::process
+function.
+
+WWW: http://search.cpan.org/dist/Template-Extract/
diff --git a/textproc/p5-Template-Extract/pkg-plist b/textproc/p5-Template-Extract/pkg-plist
new file mode 100644
index 000000000000..97d0f66ecf97
--- /dev/null
+++ b/textproc/p5-Template-Extract/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Template/Extract.pm
+%%SITE_PERL%%/Template/Extract/Compile.pm
+%%SITE_PERL%%/Template/Extract/Parser.pm
+%%SITE_PERL%%/Template/Extract/Run.pm
+@dirrm %%SITE_PERL%%/Template/Extract
+@unexec rmdir %D/%%SITE_PERL%%/Template 2>/dev/null || true
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Extract/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Extract
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template 2>/dev/null || true