aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Test-Perl-Critic/Makefile
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2007-07-28 11:47:09 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2007-07-28 11:47:09 +0000
commit1078666f87acf170bb6579cc823631dad567c86b (patch)
tree5ac0afc2de3b6eef62ac1be66ed4f2e512b7be66 /textproc/p5-Test-Perl-Critic/Makefile
parentb77a66d461736a3553ea06c6110bb21234079ecc (diff)
Add p5-Test-Perl-Critic, Test::Perl::Critic wraps the Perl::Critic engine in
a convenient subroutine suitable for test programs written using the Test::More framework. This makes it easy to integrate coding-standards enforcement into the build process. Approved by: rafan (mentor, implicit)
Notes
Notes: svn path=/head/; revision=196457
Diffstat (limited to 'textproc/p5-Test-Perl-Critic/Makefile')
-rw-r--r--textproc/p5-Test-Perl-Critic/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/textproc/p5-Test-Perl-Critic/Makefile b/textproc/p5-Test-Perl-Critic/Makefile
new file mode 100644
index 000000000000..b42f9611c0fa
--- /dev/null
+++ b/textproc/p5-Test-Perl-Critic/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Test-Perl-Critic
+# Date created: 2007/06/07
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Perl-Critic
+PORTVERSION= 1.01
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test/THALJEF/testperlcritic
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Use Perl::Critic in test programs
+
+BUILD_DEPENDS= p5-Perl-Critic>=0:${PORTSDIR}/textproc/p5-Perl-Critic
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Perl::Critic.3
+
+.include <bsd.port.mk>