aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-CSV-Simple
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2005-12-17 16:46:46 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2005-12-17 16:46:46 +0000
commit55b7c5608ada56d4549b4689681b25ccb1d122a0 (patch)
tree8722e4611664343d8f6c7d3b87583e5298d83f1d /textproc/p5-Text-CSV-Simple
parent43a5211a7e5ccba81bbc0f8314f1216cf8dcf364 (diff)
downloadports-55b7c5608ada56d4549b4689681b25ccb1d122a0.tar.gz
ports-55b7c5608ada56d4549b4689681b25ccb1d122a0.zip
Notes
Diffstat (limited to 'textproc/p5-Text-CSV-Simple')
-rw-r--r--textproc/p5-Text-CSV-Simple/Makefile27
-rw-r--r--textproc/p5-Text-CSV-Simple/distinfo3
-rw-r--r--textproc/p5-Text-CSV-Simple/pkg-descr14
-rw-r--r--textproc/p5-Text-CSV-Simple/pkg-plist6
4 files changed, 50 insertions, 0 deletions
diff --git a/textproc/p5-Text-CSV-Simple/Makefile b/textproc/p5-Text-CSV-Simple/Makefile
new file mode 100644
index 000000000000..090bcbdf5ad7
--- /dev/null
+++ b/textproc/p5-Text-CSV-Simple/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Text-CSV-Simple
+# Date Created: 17 Dec, 2005
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-CSV-Simple
+PORTVERSION= 1.00
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl module for Simpler parsing of CSV files
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Text/CSV_XS.pm:${PORTSDIR}/textproc/p5-Text-CSV_XS \
+ ${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp \
+ ${SITE_PERL}/Class/Trigger.pm:${PORTSDIR}/devel/p5-Class-Trigger
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::CSV::Simple.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-CSV-Simple/distinfo b/textproc/p5-Text-CSV-Simple/distinfo
new file mode 100644
index 000000000000..0b1625679654
--- /dev/null
+++ b/textproc/p5-Text-CSV-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (Text-CSV-Simple-1.00.tar.gz) = 03eaf9232c84716e8a70ea1dcd9edfb2
+SHA256 (Text-CSV-Simple-1.00.tar.gz) = 58842240654d398fcac7e0ae5817d50b062bef4829c40de1191a3698b7623a2d
+SIZE (Text-CSV-Simple-1.00.tar.gz) = 4571
diff --git a/textproc/p5-Text-CSV-Simple/pkg-descr b/textproc/p5-Text-CSV-Simple/pkg-descr
new file mode 100644
index 000000000000..033d40e71159
--- /dev/null
+++ b/textproc/p5-Text-CSV-Simple/pkg-descr
@@ -0,0 +1,14 @@
+Parsing CSV files is nasty. It seems so simple, but it usually
+isn't. Thankfully Text::CSV_XS takes care of most of that nastiness
+for us.
+
+Like many modules which have to deal with all manner of nastiness and
+edge cases, however, it can be clumsy to work with in the simple case.
+
+Thus this module.
+
+We simply provide a little wrapper around Text::CSV_XS to streamline
+the common case scenario. (Or at least my common case scenario; feel
+free to write your own wrapper if this one doesn't do what you want).
+
+WWW: http://search.cpan.org/search?dist=Text-CSV-Simple
diff --git a/textproc/p5-Text-CSV-Simple/pkg-plist b/textproc/p5-Text-CSV-Simple/pkg-plist
new file mode 100644
index 000000000000..4eb38dcad786
--- /dev/null
+++ b/textproc/p5-Text-CSV-Simple/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Text/CSV/Simple.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/CSV/Simple/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/CSV/Simple
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/CSV 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Text/CSV 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Text 2>/dev/null || true