aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-Diff3/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-29 20:36:28 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-29 20:36:28 +0000
commit0d8a30e5985de5bdea4d7ad7b9156d5c97f9793e (patch)
tree3d503022a29d6fb878bd39d5ab70b8f194664c37 /textproc/p5-Text-Diff3/Makefile
parent066ac7b976031d84ce56e3b658848ae9604e210b (diff)
Notes
Diffstat (limited to 'textproc/p5-Text-Diff3/Makefile')
-rw-r--r--textproc/p5-Text-Diff3/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/textproc/p5-Text-Diff3/Makefile b/textproc/p5-Text-Diff3/Makefile
new file mode 100644
index 000000000000..53f66fc84df8
--- /dev/null
+++ b/textproc/p5-Text-Diff3/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: p5-Text-Diff3
+# Date created: 29 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Diff3
+PORTVERSION= 0.06
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Compute three-way differences between texts
+
+MAN3= Text::Diff3.3 \
+ Text::Diff3::Base.3 \
+ Text::Diff3::Diff3.3 \
+ Text::Diff3::DiffHeckel.3 \
+ Text::Diff3::Factory.3 \
+ Text::Diff3::List.3 \
+ Text::Diff3::ListMixin.3 \
+ Text::Diff3::Range2.3 \
+ Text::Diff3::Range3.3 \
+ Text::Diff3::Text.3
+
+PERL_CONFIGURE= yes
+
+post-patch:
+ @${RM} ${WRKSRC}/*.orig
+ @${MKDIR} ${WRKSRC}/examples
+ @${MV} ${WRKSRC}/*.pl ${WRKSRC}/examples
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>