aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-FixedLength-Extra/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-05-11 16:11:51 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-05-11 16:11:51 +0000
commit1dbeb6248ddec23ecd850437a425a99a66a3de78 (patch)
treedcfb36d59187a82808b13c17b48c22976e861a88 /textproc/p5-Text-FixedLength-Extra/Makefile
parent959f7cff9ab29bbe3e3798a4753180f22bf6519c (diff)
downloadports-1dbeb6248ddec23ecd850437a425a99a66a3de78.tar.gz
ports-1dbeb6248ddec23ecd850437a425a99a66a3de78.zip
Notes
Diffstat (limited to 'textproc/p5-Text-FixedLength-Extra/Makefile')
-rw-r--r--textproc/p5-Text-FixedLength-Extra/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/textproc/p5-Text-FixedLength-Extra/Makefile b/textproc/p5-Text-FixedLength-Extra/Makefile
new file mode 100644
index 000000000000..ba0112938ce3
--- /dev/null
+++ b/textproc/p5-Text-FixedLength-Extra/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: textproc/p5-Text-FixedLength-Extra
+# Date created: 30 December 2000
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-FixedLength-Extra
+PORTVERSION= 1.0
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Text/FixedLength.pm:${PORTSDIR}/textproc/p5-Text-FixedLength
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500007
+BROKEN="Requires perl that has 'our' keyword"
+.endif
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= Text::FixedLength::Extra.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.post.mk>