aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-NeatTemplate/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-20 04:51:29 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-20 04:51:29 +0000
commitd13c67f51e56f998dc0adf55a2cd7945340a6a24 (patch)
tree0d1eaddd5beacabc9fe09f2ee2e819a9d449afe7 /textproc/p5-Text-NeatTemplate/Makefile
parent7bd57ec6ddaf17f06847b48b114d5363630e1a3d (diff)
Notes
Diffstat (limited to 'textproc/p5-Text-NeatTemplate/Makefile')
-rw-r--r--textproc/p5-Text-NeatTemplate/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/p5-Text-NeatTemplate/Makefile b/textproc/p5-Text-NeatTemplate/Makefile
new file mode 100644
index 000000000000..41b51442949c
--- /dev/null
+++ b/textproc/p5-Text-NeatTemplate/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: textproc/p5-Text-NeatTemplate
+# Date created: Wed Sep 20 12:37:36 CST 2006
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-NeatTemplate
+PORTVERSION= 0.08
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A fast, middleweight template engine
+
+PERL_MODBUILD= yes
+
+MAN3= Text::NeatTemplate.3
+
+post-patch:
+ ${CHMOD} u+w ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>