aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-Query/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-31 05:42:03 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-31 05:42:03 +0000
commit36f8276f2aa5c0c308adb8d0c62feefd6ac28f9f (patch)
tree30197b8b09ad780e6fb61e092d1e4b0a9eda0e18 /textproc/p5-Text-Query/Makefile
parent3e33b0de4b0be58479eaa9f2cc45b5b8261e3b1f (diff)
Notes
Diffstat (limited to 'textproc/p5-Text-Query/Makefile')
-rw-r--r--textproc/p5-Text-Query/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/textproc/p5-Text-Query/Makefile b/textproc/p5-Text-Query/Makefile
new file mode 100644
index 000000000000..053a32420687
--- /dev/null
+++ b/textproc/p5-Text-Query/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: textproc/p5-Text-Query
+# Date created: 31 December 2000
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Query
+PORTVERSION= 0.07
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= Text::Query.3 Text::Query::Build.3 \
+ Text::Query::BuildAdvancedString.3 \
+ Text::Query::BuildSimpleString.3 Text::Query::Optimize.3 \
+ Text::Query::Parse.3 Text::Query::ParseAdvanced.3 \
+ Text::Query::ParseSimple.3 Text::Query::Solve.3 \
+ Text::Query::SolveAdvancedString.3 \
+ Text::Query::SolveSimpleString.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+pre-patch:
+ @${PERL} -pi -e 's/factor\(\$$self\)/\&factor(\$$self)/' \
+ ${WRKSRC}/lib/Text/Query/ParseAdvanced.pm
+
+.include <bsd.port.mk>