aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-Quote
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-08-02 01:20:01 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-08-02 01:20:01 +0000
commit1eb712f0b320e0ecddcdb3ba60a82c9b4555951a (patch)
tree0677e950f98339399a388fcf66904b5679e7987a /textproc/p5-Text-Quote
parentd32a34a2008942e60a87666d92124422c581dda7 (diff)
downloadports-1eb712f0b320e0ecddcdb3ba60a82c9b4555951a.tar.gz
ports-1eb712f0b320e0ecddcdb3ba60a82c9b4555951a.zip
Notes
Diffstat (limited to 'textproc/p5-Text-Quote')
-rw-r--r--textproc/p5-Text-Quote/Makefile27
-rw-r--r--textproc/p5-Text-Quote/distinfo3
-rw-r--r--textproc/p5-Text-Quote/pkg-descr6
-rw-r--r--textproc/p5-Text-Quote/pkg-plist5
4 files changed, 41 insertions, 0 deletions
diff --git a/textproc/p5-Text-Quote/Makefile b/textproc/p5-Text-Quote/Makefile
new file mode 100644
index 000000000000..e38066ae57af
--- /dev/null
+++ b/textproc/p5-Text-Quote/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: Text::Quote
+# Date created: Jul 29, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Quote
+PORTVERSION= 0.3
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Quotes strings as required for perl to eval them back correctly
+
+BUILD_DEPENDS= p5-Compress-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
+ p5-Carp-Assert>=0:${PORTSDIR}/devel/p5-Carp-Assert
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::Quote.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Quote/distinfo b/textproc/p5-Text-Quote/distinfo
new file mode 100644
index 000000000000..686950cb43d3
--- /dev/null
+++ b/textproc/p5-Text-Quote/distinfo
@@ -0,0 +1,3 @@
+MD5 (Text-Quote-0.3.tar.gz) = c203a9897c8bb6570fd0444139ef3e0f
+SHA256 (Text-Quote-0.3.tar.gz) = bd0e75b670c3869be57b57a6332c2cf735652ee06853f236d92b0e423e3bac76
+SIZE (Text-Quote-0.3.tar.gz) = 12068
diff --git a/textproc/p5-Text-Quote/pkg-descr b/textproc/p5-Text-Quote/pkg-descr
new file mode 100644
index 000000000000..17e8b7969340
--- /dev/null
+++ b/textproc/p5-Text-Quote/pkg-descr
@@ -0,0 +1,6 @@
+Text::Quote is intended as a utility class for other classes that need to be
+able to produce valid perl quoted strings. It posses routines to determine
+the ideal quote character to correctly quote hash keys, to correctly quote
+and encode binary strings.
+
+WWW: http://search.cpan.org/dist/Text-Quote/
diff --git a/textproc/p5-Text-Quote/pkg-plist b/textproc/p5-Text-Quote/pkg-plist
new file mode 100644
index 000000000000..a23b3a27d99d
--- /dev/null
+++ b/textproc/p5-Text-Quote/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Text/Quote.pm
+@dirrmtry %%SITE_PERL%%/Text
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Quote/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Quote
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text