aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-Quoted/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-14 12:21:31 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-14 12:21:31 +0000
commitba156ff1479201f50eb1447c71f21a579f545d4c (patch)
treee6e3ae85f96f21f73f5a2d0638f7a1c1ffa615f7 /textproc/p5-Text-Quoted/Makefile
parent77f47a7268b11cd519a300645f0897db04085ede (diff)
downloadports-ba156ff1479201f50eb1447c71f21a579f545d4c.tar.gz
ports-ba156ff1479201f50eb1447c71f21a579f545d4c.zip
Notes
Diffstat (limited to 'textproc/p5-Text-Quoted/Makefile')
-rw-r--r--textproc/p5-Text-Quoted/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/textproc/p5-Text-Quoted/Makefile b/textproc/p5-Text-Quoted/Makefile
new file mode 100644
index 000000000000..78bfe7b14d7c
--- /dev/null
+++ b/textproc/p5-Text-Quoted/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Text-Quoted
+# Date created: Mon April 14th, 2003
+# Whom: Erwin Lansing <erwin@lansing.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Quoted
+PORTVERSION= 1.2
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@lansing.dk
+COMMENT= Text::Quoted - Extract the structure of a quoted mail message
+
+BUILD_DEPENDS= ${SITE_PERL}/Text/Autoformat.pm:${PORTSDIR}/textproc/p5-Text-Autoformat \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::Quoted.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>