aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-Template
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2012-04-06 13:34:23 +0000
committerFrederic Culot <culot@FreeBSD.org>2012-04-06 13:34:23 +0000
commit3be13e4d848669fc5ae7564a71507f08fe9e865c (patch)
tree208effb8640047c72416c13054dee37f0c1c5428 /textproc/p5-Text-Template
parentb5876a0d5bf64f1a2dc911b0f28301785d41b3d4 (diff)
downloadports-3be13e4d848669fc5ae7564a71507f08fe9e865c.tar.gz
ports-3be13e4d848669fc5ae7564a71507f08fe9e865c.zip
Notes
Diffstat (limited to 'textproc/p5-Text-Template')
-rw-r--r--textproc/p5-Text-Template/Makefile7
-rw-r--r--textproc/p5-Text-Template/files/patch-lib_Text_Template.pm10
2 files changed, 17 insertions, 0 deletions
diff --git a/textproc/p5-Text-Template/Makefile b/textproc/p5-Text-Template/Makefile
index f68920b3224e..aa15d903e07e 100644
--- a/textproc/p5-Text-Template/Makefile
+++ b/textproc/p5-Text-Template/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Text-Template
PORTVERSION= 1.45
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= http://perl.plover.com/Template/ \
CPAN
@@ -15,8 +16,14 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Expand template text with embedded Perl
+LICENSE= ART10 GPLv2
+LICENSE_COMB= dual
+
PERL_CONFIGURE= YES
MAN3= Text::Template.3 Text::Template::Preprocess.3
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.orig" -delete
+
.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Template/files/patch-lib_Text_Template.pm b/textproc/p5-Text-Template/files/patch-lib_Text_Template.pm
new file mode 100644
index 000000000000..890a01d0a59e
--- /dev/null
+++ b/textproc/p5-Text-Template/files/patch-lib_Text_Template.pm
@@ -0,0 +1,10 @@
+--- lib/Text/Template.pm.orig 2008-04-16 18:38:08.000000000 -0500
++++ lib/Text/Template.pm 2012-03-17 06:44:14.882739137 -0500
+@@ -428,6 +428,8 @@
+ foreach my $key (keys %$hash) {
+ undef $hash->{$key};
+ }
++ %$hash = ();
++ delete $Text::Template::{$s."::"};
+ }
+ }