aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Time-Human
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2004-06-29 09:07:17 +0000
committerPeter Pentchev <roam@FreeBSD.org>2004-06-29 09:07:17 +0000
commit2c6ade3eb4da460ca3926ae045f85769a39f9e4e (patch)
tree722376429f6d4ca759451ecca6e554628e255179 /textproc/p5-Time-Human
parentd844b23ecdfe82d44b8d671e98e1603fdcd15cb1 (diff)
downloadports-2c6ade3eb4da460ca3926ae045f85769a39f9e4e.tar.gz
ports-2c6ade3eb4da460ca3926ae045f85769a39f9e4e.zip
Okay, here's a Perl 5.00503-friendly version.
Notes
Notes: svn path=/head/; revision=112527
Diffstat (limited to 'textproc/p5-Time-Human')
-rw-r--r--textproc/p5-Time-Human/Makefile3
-rw-r--r--textproc/p5-Time-Human/files/Human.pm-5005.patch59
-rw-r--r--textproc/p5-Time-Human/pkg-plist4
3 files changed, 63 insertions, 3 deletions
diff --git a/textproc/p5-Time-Human/Makefile b/textproc/p5-Time-Human/Makefile
index 9e4e5e20e800..f164fe050f2d 100644
--- a/textproc/p5-Time-Human/Makefile
+++ b/textproc/p5-Time-Human/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Time-Human
PORTVERSION= 1.02
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Time
@@ -22,7 +23,7 @@ MAN3= Time::Human.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-BROKEN= Does not build with Perl 5.005.
+EXTRA_PATCHES+= ${PATCHDIR}/Human.pm-5005.patch
.endif
.include <bsd.port.post.mk>
diff --git a/textproc/p5-Time-Human/files/Human.pm-5005.patch b/textproc/p5-Time-Human/files/Human.pm-5005.patch
new file mode 100644
index 000000000000..84bd659d5f3a
--- /dev/null
+++ b/textproc/p5-Time-Human/files/Human.pm-5005.patch
@@ -0,0 +1,59 @@
+--- Human.pm.orig Thu May 30 14:01:27 2002
++++ Human.pm Tue Jun 29 11:52:35 2004
+@@ -1,12 +1,15 @@
++#!/usr/bin/perl -w
++
+ package Time::Human;
+
+-require 5.005_62;
++require 5.005_03;
+ use strict;
+-use warnings;
+
+ require Exporter;
+
+-our @ISA = qw(Exporter);
++use vars qw/@ISA $VERSION %EXPORT_TAGS @EXPORT_OK @EXPORT
++ %templates $Language $Evening $Night/;
++@ISA = qw(Exporter);
+
+ # Items to export into callers namespace by default. Note: do not export
+ # names by default without a very good reason. Use EXPORT_OK instead.
+@@ -15,19 +18,19 @@
+ # This allows declaration use Time::Human ':all';
+ # If you do not need this, moving things directly into @EXPORT or @EXPORT_OK
+ # will save memory.
+-our %EXPORT_TAGS = ( 'all' => [ qw(
++%EXPORT_TAGS = ( 'all' => [ qw(
+ humantime
+ ) ] );
+
+-our @EXPORT_OK = ( @{ $EXPORT_TAGS{'all'} } );
++@EXPORT_OK = ( @{ $EXPORT_TAGS{'all'} } );
+
+-our @EXPORT = qw(
++@EXPORT = qw(
+ humanize
+
+ );
+-our $VERSION = '1.02';
++$VERSION = '1.02';
+
+-our %templates = (
++%templates = (
+
+ English => {
+ numbers => [ qw(one two three four five six seven eight nine ten eleven twelve) ],
+@@ -43,9 +46,9 @@
+ }
+ );
+
+-our $Language = "English";
+-our $Evening = 18;
+-our $Night = 22;
++$Language = "English";
++$Evening = 18;
++$Night = 22;
+
+ # Preloaded methods go here.
+
diff --git a/textproc/p5-Time-Human/pkg-plist b/textproc/p5-Time-Human/pkg-plist
index 93a87af33d7f..68be7dc8675f 100644
--- a/textproc/p5-Time-Human/pkg-plist
+++ b/textproc/p5-Time-Human/pkg-plist
@@ -1,5 +1,5 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Time/Human/.packlist
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Time/Human
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Time
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Time 2>/dev/null || true
%%SITE_PERL%%/Time/Human.pm
-@dirrm %%SITE_PERL%%/Time
+@unexec rmdir %D/%%SITE_PERL%%/Time 2>/dev/null || true