aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-UML-Class-Simple/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2007-05-03 10:21:05 +0000
committerLars Thegler <lth@FreeBSD.org>2007-05-03 10:21:05 +0000
commit325348f568497425adc293859a96b8fd0b02b890 (patch)
treea8d7f4d45846e33c25bc6932060571fe3bf3f5a0 /textproc/p5-UML-Class-Simple/Makefile
parent5a1c645f1cd90fa156750773b44684919e8982ba (diff)
Add p5-UML-Class-Simple 0.09, render simple UML class diagrams, by
loading the code.
Notes
Notes: svn path=/head/; revision=191472
Diffstat (limited to 'textproc/p5-UML-Class-Simple/Makefile')
-rw-r--r--textproc/p5-UML-Class-Simple/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/textproc/p5-UML-Class-Simple/Makefile b/textproc/p5-UML-Class-Simple/Makefile
new file mode 100644
index 000000000000..03207bac34c9
--- /dev/null
+++ b/textproc/p5-UML-Class-Simple/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: textproc/p5-UML-Class-Simple
+# Date created: 03 May 2007
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= UML-Class-Simple
+PORTVERSION= 0.09
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= UML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Render simple UML class diagrams, by loading the code
+
+RUN_DEPENDS= p5-PPI>0:${PORTSDIR}/textproc/p5-PPI \
+ p5-Template-Toolkit>0:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-YAML-Syck>0:${PORTSDIR}/textproc/p5-YAML-Syck \
+ p5-IPC-Run3>0:${PORTSDIR}/devel/p5-IPC-Run3 \
+ p5-Class-Inspector>=1.16:${PORTSDIR}/devel/p5-Class-Inspector \
+ p5-List-MoreUtils>0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-File-Slurp>0:${PORTSDIR}/devel/p5-File-Slurp \
+ dot:${PORTSDIR}/graphics/graphviz
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= umlclass.pl.1
+MAN3= UML::Class::Simple.3
+
+post-patch:
+ ${PERL} -pi -e '$$_="" if /auto_install/' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>