aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Atom
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-12-29 17:01:42 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-12-29 17:01:42 +0000
commit49c40d2c4a70df7993be2dbc2641d3e872260405 (patch)
tree0f7f4de6e43e65d472812252d534c92fb2252b90 /textproc/p5-XML-Atom
parent1bcb81b7c9bc03f5cd64a0e85d3a5ee0d8d487cc (diff)
Notes
Diffstat (limited to 'textproc/p5-XML-Atom')
-rw-r--r--textproc/p5-XML-Atom/Makefile42
-rw-r--r--textproc/p5-XML-Atom/distinfo1
-rw-r--r--textproc/p5-XML-Atom/files/patch-Makefile.PL20
-rw-r--r--textproc/p5-XML-Atom/pkg-descr6
-rw-r--r--textproc/p5-XML-Atom/pkg-plist14
5 files changed, 83 insertions, 0 deletions
diff --git a/textproc/p5-XML-Atom/Makefile b/textproc/p5-XML-Atom/Makefile
new file mode 100644
index 000000000000..928ff2e642f8
--- /dev/null
+++ b/textproc/p5-XML-Atom/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: p5-XML-Atom
+# Date created: Dec 27 2003
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Atom
+PORTVERSION= 0.04
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= Perl5 modules for Atom feed and API implementation
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
+ ${SITE_PERL}/${PERL_ARCH}/XML/LibXSLT.pm:${PORTSDIR}/textproc/p5-XML-LibXSLT \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Atom.3 \
+ XML::Atom::API.3 \
+ XML::Atom::Entry.3 \
+ XML::Atom::Feed.3 \
+ XML::Atom::Person.3 \
+ XML::Atom::Util.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-Atom/distinfo b/textproc/p5-XML-Atom/distinfo
new file mode 100644
index 000000000000..25fdc747ae7c
--- /dev/null
+++ b/textproc/p5-XML-Atom/distinfo
@@ -0,0 +1 @@
+MD5 (XML-Atom-0.04.tar.gz) = b707a525609efaf2b5274fde32641e01
diff --git a/textproc/p5-XML-Atom/files/patch-Makefile.PL b/textproc/p5-XML-Atom/files/patch-Makefile.PL
new file mode 100644
index 000000000000..7d577262059f
--- /dev/null
+++ b/textproc/p5-XML-Atom/files/patch-Makefile.PL
@@ -0,0 +1,20 @@
+--- Makefile.PL.orig Mon Sep 8 15:33:37 2003
++++ Makefile.PL Sat Dec 27 19:39:19 2003
+@@ -3,7 +3,7 @@
+ use ExtUtils::MakeMaker;
+ use strict;
+
+-use ExtUtils::AutoInstall (
++q{use ExtUtils::AutoInstall (
+ -core => [
+ 'XML::LibXML' => 1.54,
+ 'MIME::Base64' => 0,
+@@ -24,7 +24,7 @@
+ -default => 0,
+ 'XML::LibXSLT' => 0,
+ ],
+-);
++)};
+
+ WriteMakefile(
+ NAME => 'XML::Atom',
diff --git a/textproc/p5-XML-Atom/pkg-descr b/textproc/p5-XML-Atom/pkg-descr
new file mode 100644
index 000000000000..5de6ef0623df
--- /dev/null
+++ b/textproc/p5-XML-Atom/pkg-descr
@@ -0,0 +1,6 @@
+Atom is a syndication, API, and archiving format for weblogs and other data.
+XML::Atom implements the feed format as well as a client for the API.
+
+WWW: http://search.cpan.org/dist/XML-Atom/
+
+Author: Benjamin Trott <cpan@stupidfool.org>
diff --git a/textproc/p5-XML-Atom/pkg-plist b/textproc/p5-XML-Atom/pkg-plist
new file mode 100644
index 000000000000..ea8ba0c74dce
--- /dev/null
+++ b/textproc/p5-XML-Atom/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/XML/Atom.pm
+%%SITE_PERL%%/XML/Atom/API.pm
+%%SITE_PERL%%/XML/Atom/Content.pm
+%%SITE_PERL%%/XML/Atom/Entry.pm
+%%SITE_PERL%%/XML/Atom/ErrorHandler.pm
+%%SITE_PERL%%/XML/Atom/Feed.pm
+%%SITE_PERL%%/XML/Atom/Person.pm
+%%SITE_PERL%%/XML/Atom/Thing.pm
+%%SITE_PERL%%/XML/Atom/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Atom/.packlist
+@dirrm %%SITE_PERL%%/XML/Atom
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Atom
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/XML 2>/dev/null || true