aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Compile/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-26 08:59:45 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-26 08:59:45 +0000
commit671e48e5a0d8dc7e98503a31fc9cc8a30bdfeeb5 (patch)
tree3e0b7ac3573949f11aac697915ae8aab2265be04 /textproc/p5-XML-Compile/Makefile
parent085ab5a6791fa6af6c562b0dbc7ab7b4bc269564 (diff)
Notes
Diffstat (limited to 'textproc/p5-XML-Compile/Makefile')
-rw-r--r--textproc/p5-XML-Compile/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/textproc/p5-XML-Compile/Makefile b/textproc/p5-XML-Compile/Makefile
new file mode 100644
index 000000000000..575531a6f65d
--- /dev/null
+++ b/textproc/p5-XML-Compile/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-XML-Compile
+# Date created: 2006-08-29
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Compile
+PORTVERSION= 0.05
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Compilation based XML processing
+
+RUN_DEPENDS= p5-XML-LibXML>=1.58:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-Regexp-Common>=2.00:${PORTSDIR}/textproc/p5-Regexp-Common
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Compile.3 XML::Compile::Schema.3 \
+ XML::Compile::Schema::BuiltInFacets.3 \
+ XML::Compile::Schema::BuiltInStructs.3 \
+ XML::Compile::Schema::BuiltInTypes.3 \
+ XML::Compile::Schema::Instance.3 \
+ XML::Compile::Schema::NameSpaces.3 \
+ XML::Compile::Schema::Specs.3 \
+ XML::Compile::Schema::Translate.3
+
+.include <bsd.port.mk>