aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-DBMS/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-06-09 14:29:26 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-06-09 14:29:26 +0000
commit2aad458bb54c17bc8a4c0d34b467f29b95e5c825 (patch)
treebc8439ac3898aa1d2640bd1d778db15b3ed99a03 /textproc/p5-XML-DBMS/Makefile
parent07f7bc041c995988b7a3abcc147c8b8ce0c2c983 (diff)
downloadports-2aad458bb54c17bc8a4c0d34b467f29b95e5c825.tar.gz
ports-2aad458bb54c17bc8a4c0d34b467f29b95e5c825.zip
Notes
Diffstat (limited to 'textproc/p5-XML-DBMS/Makefile')
-rw-r--r--textproc/p5-XML-DBMS/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/textproc/p5-XML-DBMS/Makefile b/textproc/p5-XML-DBMS/Makefile
new file mode 100644
index 000000000000..fb6df49d6061
--- /dev/null
+++ b/textproc/p5-XML-DBMS/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: XML::DBMS
+# Date created: 18 Dec 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-DBMS
+PORTVERSION= 1.03
+CATEGORIES= textproc databases perl5
+MASTER_SITES= ftp://ftp.rpbourret.com/
+PKGNAMEPREFIX= p5-
+DISTNAME= perl-xml-dbms-1.03
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= skv@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/Parser/PerlSAX.pm:${PORTSDIR}/textproc/p5-libxml \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PERL_CONFIGURE= yes
+
+post-extract:
+ @${FIND} ${WRKSRC} -type f | \
+ xargs ${PERL} -pi -e 's/\x0D(?=\x0A)//g'
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/*.* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>