aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Feed/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-11-14 09:29:10 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-11-14 09:29:10 +0000
commit48755bd36c2b55cb37a03b7f517fe1f9669bdd1e (patch)
tree3c9d3d9bb7d9627641168aa295d45e362ff6eac3 /textproc/p5-XML-Feed/Makefile
parent4776874a8bc93acea5cc21323a0a1611e9a9d096 (diff)
Notes
Diffstat (limited to 'textproc/p5-XML-Feed/Makefile')
-rw-r--r--textproc/p5-XML-Feed/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/textproc/p5-XML-Feed/Makefile b/textproc/p5-XML-Feed/Makefile
index 2b02a2be92cd..9aad113a0415 100644
--- a/textproc/p5-XML-Feed/Makefile
+++ b/textproc/p5-XML-Feed/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME= XML-Feed
-PORTVERSION= 0.23
+PORTVERSION= 0.30
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/0$//}
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 modules for Syndication feed parser and auto-discovery
-BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS= p5-Class-ErrorHandler>=0:${PORTSDIR}/devel/p5-Class-ErrorHandler \
p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
p5-DateTime-Format-Mail>=0:${PORTSDIR}/devel/p5-DateTime-Format-Mail \
@@ -22,10 +22,11 @@ RUN_DEPENDS= p5-Class-ErrorHandler>=0:${PORTSDIR}/devel/p5-Class-ErrorHandler \
p5-Feed-Find>=0:${PORTSDIR}/www/p5-Feed-Find \
p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-URI-Fetch>=0:${PORTSDIR}/www/p5-URI-Fetch \
- p5-XML-Atom>=0:${PORTSDIR}/textproc/p5-XML-Atom \
+ p5-XML-Atom>=0.23:${PORTSDIR}/textproc/p5-XML-Atom \
p5-XML-LibXML>=1.66:${PORTSDIR}/textproc/p5-XML-LibXML \
p5-XML-RSS>=1.31:${PORTSDIR}/textproc/p5-XML-RSS \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -33,4 +34,14 @@ MAN3= XML::Feed.3 \
XML::Feed::Content.3 \
XML::Feed::Entry.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.if ${PERL_LEVEL} < 500905
+RUN_DEPENDS+= p5-Module-Pluggable>=0:${PORTSDIR}/devel/p5-Module-Pluggable
+.endif
+
+.include <bsd.port.post.mk>