aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Handler-Dtd2Html/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-12 03:41:58 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-12 03:41:58 +0000
commit96490a9b809f3e08c8346bd5a4b35b65b50e8004 (patch)
treeca1b64ad8c862e4082528d14c5e0f7f1436c3edb /textproc/p5-XML-Handler-Dtd2Html/Makefile
parent7f125a2ae70bfcd6934f10f741105911be207431 (diff)
downloadports-96490a9b809f3e08c8346bd5a4b35b65b50e8004.tar.gz
ports-96490a9b809f3e08c8346bd5a4b35b65b50e8004.zip
Notes
Diffstat (limited to 'textproc/p5-XML-Handler-Dtd2Html/Makefile')
-rw-r--r--textproc/p5-XML-Handler-Dtd2Html/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/textproc/p5-XML-Handler-Dtd2Html/Makefile b/textproc/p5-XML-Handler-Dtd2Html/Makefile
new file mode 100644
index 000000000000..975fa039a274
--- /dev/null
+++ b/textproc/p5-XML-Handler-Dtd2Html/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: XML-Handler-Dtd2Html
+# Date created: 2006/07/11
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Handler-Dtd2Html
+PORTVERSION= 0.41
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= SAX2 handler for generate a Html documentation from a DTD
+
+BUILD_DEPENDS= p5-Parse-RecDescent>=1.94:${PORTSDIR}/devel/p5-Parse-RecDescent \
+ p5-libxml>=0.08:${PORTSDIR}/textproc/p5-libxml \
+ p5-XML-Parser>=2.3:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-XML-SAX-Expat>=0.37:${PORTSDIR}/textproc/p5-XML-SAX-Expat \
+ p5-XML-SAX-Writer>=0.44:${PORTSDIR}/textproc/p5-XML-SAX-Writer \
+ p5-HTML-Template>=2.8:${PORTSDIR}/www/p5-HTML-Template
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= dtd2html.pl.1
+MAN1PREFIX= ${PREFIX}
+MAN3= XML::Handler::Dtd2Html.3
+
+.include <bsd.port.mk>