aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-LibXML-Common/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-02-27 04:59:50 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-02-27 04:59:50 +0000
commit7520ee9ed7eb7d47a387ef89e86f1b03b3172a1c (patch)
treeca6ecb78b13ab012716fff49a8084fd06bd5d996 /textproc/p5-XML-LibXML-Common/Makefile
parentc8bcfb8d9d2de92518417612b1339af8219f19c9 (diff)
Notes
Diffstat (limited to 'textproc/p5-XML-LibXML-Common/Makefile')
-rw-r--r--textproc/p5-XML-LibXML-Common/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/p5-XML-LibXML-Common/Makefile b/textproc/p5-XML-LibXML-Common/Makefile
new file mode 100644
index 000000000000..47f638220d0f
--- /dev/null
+++ b/textproc/p5-XML-LibXML-Common/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: XML::LibXML::Common
+# Date created: 27 February 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-LibXML-Common
+PORTVERSION= 0.12
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+# Feel free to update this port when the CPAN module is updated
+MAINTAINER= knu@FreeBSD.org
+COMMENT= Routines and Constants common for XML::LibXML and XML::GDOME
+
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= INC='-I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2'
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= XML::LibXML::Common.3
+
+.include <bsd.port.mk>