aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-LibXML-PrettyPrint/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-05 17:09:54 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-05 17:09:54 +0000
commit7183655863c4edeed8151decc38e231fae155b6d (patch)
treecb456f659267cf5a4a7cc33a93808400a3f37b37 /textproc/p5-XML-LibXML-PrettyPrint/Makefile
parent2ce578fdcf1e9f7c7e98cf545b4a79eaf4f3063a (diff)
downloadports-7183655863c4edeed8151decc38e231fae155b6d.tar.gz
ports-7183655863c4edeed8151decc38e231fae155b6d.zip
Notes
Diffstat (limited to 'textproc/p5-XML-LibXML-PrettyPrint/Makefile')
-rw-r--r--textproc/p5-XML-LibXML-PrettyPrint/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/p5-XML-LibXML-PrettyPrint/Makefile b/textproc/p5-XML-LibXML-PrettyPrint/Makefile
new file mode 100644
index 000000000000..cc950b6bcf15
--- /dev/null
+++ b/textproc/p5-XML-LibXML-PrettyPrint/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-XML-LibXML-PrettyPrint
+# Date created: 2011-10-21
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-LibXML-PrettyPrint
+PORTVERSION= 0.002
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Add pleasant whitespace to a DOM tree
+
+BUILD_DEPENDS= p5-Pragmatic>=0:${PORTSDIR}/devel/p5-Pragmatic \
+ p5-XML-LibXML>=1.62:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-common-sense>=0:${PORTSDIR}/devel/p5-common-sense
+RUN_DEPENDS= p5-Pragmatic>=0:${PORTSDIR}/devel/p5-Pragmatic \
+ p5-XML-LibXML>=1.62:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-common-sense>=0:${PORTSDIR}/devel/p5-common-sense
+
+PERL_CONFIGURE= 5.10.0+
+
+MAN3= XML::LibXML::PrettyPrint.3
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>