aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-LibXML
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-14 18:04:06 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-14 18:04:06 +0000
commit357917bd8e9ffddc990d859339ff03b193c3fc1d (patch)
tree8163001967314698e72281626d63f0a59c8c740f /textproc/p5-XML-LibXML
parent626fb02fa0daf006044772d041610830541aa8ac (diff)
downloadports-357917bd8e9ffddc990d859339ff03b193c3fc1d.tar.gz
ports-357917bd8e9ffddc990d859339ff03b193c3fc1d.zip
Notes
Diffstat (limited to 'textproc/p5-XML-LibXML')
-rw-r--r--textproc/p5-XML-LibXML/Makefile10
-rw-r--r--textproc/p5-XML-LibXML/pkg-install4
2 files changed, 5 insertions, 9 deletions
diff --git a/textproc/p5-XML-LibXML/Makefile b/textproc/p5-XML-LibXML/Makefile
index 0c744d37b4d1..6858a345dede 100644
--- a/textproc/p5-XML-LibXML/Makefile
+++ b/textproc/p5-XML-LibXML/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: XML::LibXML
-# Date created: 28 May 2001
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= XML-LibXML
PORTVERSION= 2.0004
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
@@ -47,7 +44,4 @@ MAN3= XML::LibXML.3 XML::LibXML::AttributeHash.3 \
XML::LibXML::XPathExpression.3 \
XML::LibXML::Common.3 XML::LibXML::RegExp.3
-post-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
.include <bsd.port.mk>
diff --git a/textproc/p5-XML-LibXML/pkg-install b/textproc/p5-XML-LibXML/pkg-install
index f3472f152b64..97ae7332e963 100644
--- a/textproc/p5-XML-LibXML/pkg-install
+++ b/textproc/p5-XML-LibXML/pkg-install
@@ -1,7 +1,9 @@
#!/bin/sh
-if [ "$2" = "XPOST-INSTALL" ]; then
+if [ "X$2" = "XPOST-INSTALL" ]; then
perl -MXML::SAX -e "XML::SAX->add_parser('XML::LibXML::SAX'.\$_)->save_parsers()"
+ perl -MXML::SAX -e "XML::SAX->add_parser('XML::LibXML::SAX::Parser'.\$_)->save_parsers()"
elif [ "X$2" = "XDEINSTALL" ]; then
perl -MXML::SAX -e "XML::SAX->remove_parser('XML::LibXML::SAX'.\$_)->save_parsers()"
+ perl -MXML::SAX -e "XML::SAX->remove_parser('XML::LibXML::SAX::Parser'.\$_)->save_parsers()"
fi