aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-LibXML
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-10 05:35:35 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-10 05:35:35 +0000
commit0a40b8e430397f8955b76a935398b6ba7dfcfa74 (patch)
tree1d34341d60f5822384603a7f432eb86eadd5294e /textproc/p5-XML-LibXML
parentf584ae010c1490254d36ccad88ffb665ead683bf (diff)
downloadports-0a40b8e430397f8955b76a935398b6ba7dfcfa74.tar.gz
ports-0a40b8e430397f8955b76a935398b6ba7dfcfa74.zip
Notes
Diffstat (limited to 'textproc/p5-XML-LibXML')
-rw-r--r--textproc/p5-XML-LibXML/Makefile6
-rw-r--r--textproc/p5-XML-LibXML/files/patch-LibXML.xs23
2 files changed, 24 insertions, 5 deletions
diff --git a/textproc/p5-XML-LibXML/Makefile b/textproc/p5-XML-LibXML/Makefile
index b23b4969cbb4..867623aef24e 100644
--- a/textproc/p5-XML-LibXML/Makefile
+++ b/textproc/p5-XML-LibXML/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML
PKGNAMEPREFIX= p5-
-MAINTAINER= skv@FreeBSD.org
+MAINTAINER= adam@migus.org
COMMENT= Interface to Gnome libxml2 library
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML/Common.pm:${PORTSDIR}/textproc/p5-XML-LibXML-Common \
@@ -36,8 +36,4 @@ MAN3= XML::LibXML.3 XML::LibXML::Attr.3 XML::LibXML::Boolean.3 \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
-.endif
-
.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-LibXML/files/patch-LibXML.xs b/textproc/p5-XML-LibXML/files/patch-LibXML.xs
new file mode 100644
index 000000000000..fa885ad6cf22
--- /dev/null
+++ b/textproc/p5-XML-LibXML/files/patch-LibXML.xs
@@ -0,0 +1,23 @@
+--- LibXML.xs.orig 2003-12-22 10:38:06.000000000 -0500
++++ LibXML.xs 2003-12-22 10:38:12.000000000 -0500
+@@ -64,20 +64,6 @@
+ }
+ #endif
+
+-#ifdef VMS
+-extern int xmlDoValidityCheckingDefaultVal;
+-#define xmlDoValidityCheckingDefaultValue xmlDoValidityCheckingDefaultVal
+-extern int xmlSubstituteEntitiesDefaultVal;
+-#define xmlSubstituteEntitiesDefaultValue xmlSubstituteEntitiesDefaultVal
+-#else
+-LIBXML_DLL_IMPORT extern int xmlDoValidityCheckingDefaultValue;
+-LIBXML_DLL_IMPORT extern int xmlSubstituteEntitiesDefaultValue;
+-#endif
+-LIBXML_DLL_IMPORT extern int xmlGetWarningsDefaultValue;
+-LIBXML_DLL_IMPORT extern int xmlKeepBlanksDefaultValue;
+-LIBXML_DLL_IMPORT extern int xmlLoadExtDtdDefaultValue;
+-LIBXML_DLL_IMPORT extern int xmlPedanticParserDefaultValue;
+-
+ #define TEST_PERL_FLAG(flag) \
+ SvTRUE(perl_get_sv(flag, FALSE)) ? 1 : 0
+