aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Liberal/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-11 05:15:55 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-11 05:15:55 +0000
commit877f6dd7ea63a5f0fecfdfb44928cefbab6da6b5 (patch)
treeb4788bb5965f290a0bfb9b93cb238adca082c644 /textproc/p5-XML-Liberal/Makefile
parentd282ddb0c6868b70199c61414c21534745fd19d8 (diff)
Notes
Diffstat (limited to 'textproc/p5-XML-Liberal/Makefile')
-rw-r--r--textproc/p5-XML-Liberal/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/textproc/p5-XML-Liberal/Makefile b/textproc/p5-XML-Liberal/Makefile
new file mode 100644
index 000000000000..3b8ccb65c498
--- /dev/null
+++ b/textproc/p5-XML-Liberal/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-XML-Liberal
+# Date created: 2006-07-09
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Liberal
+PORTVERSION= 0.12
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Super liberal XML parser that parses broken XML
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/HTML/Entities/Numbered.pm:${PORTSDIR}/textproc/p5-HTML-Entities-Numbered \
+ ${SITE_PERL}/Module/Pluggable/Fast.pm:${PORTSDIR}/devel/p5-Module-Pluggable-Fast
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Liberal.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or higher
+.endif
+
+.include <bsd.port.post.mk>